1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-24 04:19:26 +03:00
openwrt-xburst/target/linux/adm5120-2.6/patches/006-adm5120_gpio.patch
florian 47f104b513 Refresh patches with quilt, thanks Gabor !
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7617 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-06-13 18:06:38 +00:00

28 lines
991 B
Diff

Index: linux-2.6.21.1/drivers/char/Kconfig
===================================================================
--- linux-2.6.21.1.orig/drivers/char/Kconfig
+++ linux-2.6.21.1/drivers/char/Kconfig
@@ -1056,7 +1056,9 @@ config MMTIMER
The mmtimer device allows direct userspace access to the
Altix system timer.
-source "drivers/char/tpm/Kconfig"
+config ADM5120_GPIO
+ tristate "ADM5120 GPIO"
+ depends on MIPS_ADM5120
config TELCLOCK
tristate "Telecom clock driver for ATCA SBC"
Index: linux-2.6.21.1/drivers/char/Makefile
===================================================================
--- linux-2.6.21.1.orig/drivers/char/Makefile
+++ linux-2.6.21.1/drivers/char/Makefile
@@ -93,6 +93,7 @@ obj-$(CONFIG_CS5535_GPIO) += cs5535_gpio
obj-$(CONFIG_GPIO_VR41XX) += vr41xx_giu.o
obj-$(CONFIG_TANBAC_TB0219) += tb0219.o
obj-$(CONFIG_TELCLOCK) += tlclk.o
+obj-$(CONFIG_ADM5120_GPIO) += adm5120_gpio.o
obj-$(CONFIG_WATCHDOG) += watchdog/
obj-$(CONFIG_MWAVE) += mwave/