mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 03:29:22 +02:00
a16ea0db8f
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10052 3c298f89-4303-0410-b956-a3cf2f4a3e73
33 lines
1.2 KiB
Diff
33 lines
1.2 KiB
Diff
Index: linux-2.6.23-rc6/drivers/char/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.23-rc6.orig/drivers/char/Kconfig 2007-09-21 16:23:51.000000000 +0800
|
|
+++ linux-2.6.23-rc6/drivers/char/Kconfig 2007-09-21 16:24:12.000000000 +0800
|
|
@@ -928,6 +928,15 @@
|
|
To compile this driver as a module, choose M here: the
|
|
module will be called mwave.
|
|
|
|
+config AR7_GPIO
|
|
+ tristate "TI AR7 GPIO Support"
|
|
+ depends on AR7
|
|
+ help
|
|
+ Give userspace access to the GPIO pins on the Texas Instruments AR7
|
|
+ processors.
|
|
+
|
|
+ If compiled as a module, it will be called ar7_gpio.
|
|
+
|
|
config SCx200_GPIO
|
|
tristate "NatSemi SCx200 GPIO Support"
|
|
depends on SCx200
|
|
Index: linux-2.6.23-rc6/drivers/char/Makefile
|
|
===================================================================
|
|
--- linux-2.6.23-rc6.orig/drivers/char/Makefile 2007-09-21 16:23:51.000000000 +0800
|
|
+++ linux-2.6.23-rc6/drivers/char/Makefile 2007-09-21 16:24:12.000000000 +0800
|
|
@@ -89,6 +89,7 @@
|
|
obj-$(CONFIG_PPDEV) += ppdev.o
|
|
obj-$(CONFIG_NWBUTTON) += nwbutton.o
|
|
obj-$(CONFIG_NWFLASH) += nwflash.o
|
|
+obj-$(CONFIG_AR7_GPIO) += ar7_gpio.o
|
|
obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
|
|
obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
|
|
obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o
|