mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 01:30:16 +02:00
cc81d3493e
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14554 3c298f89-4303-0410-b956-a3cf2f4a3e73
51 lines
1.7 KiB
Diff
51 lines
1.7 KiB
Diff
# DP: Build and install libstdc++_pic.a library.
|
|
|
|
--- a/libstdc++-v3/src/Makefile.am
|
|
+++ b/libstdc++-v3/src/Makefile.am
|
|
@@ -234,6 +234,12 @@ CXXLINK = $(LIBTOOL) --tag CXX --mode=li
|
|
$(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LDFLAGS) -o $@
|
|
|
|
|
|
+install-exec-local:
|
|
+ifeq ($(enable_shared),yes)
|
|
+ $(AR) cru libstdc++_pic.a .libs/*.o $(top_builddir)/libsupc++/*.o
|
|
+ $(INSTALL_DATA) libstdc++_pic.a $(DESTDIR)$(toolexeclibdir)
|
|
+endif
|
|
+
|
|
# Added bits to build debug library.
|
|
if GLIBCXX_BUILD_DEBUG
|
|
all-local: build_debug
|
|
--- a/libstdc++-v3/src/Makefile.in
|
|
+++ b/libstdc++-v3/src/Makefile.in
|
|
@@ -627,7 +627,7 @@ info-am:
|
|
|
|
install-data-am: install-data-local
|
|
|
|
-install-exec-am: install-toolexeclibLTLIBRARIES
|
|
+install-exec-am: install-toolexeclibLTLIBRARIES install-exec-local
|
|
|
|
install-info: install-info-am
|
|
|
|
@@ -660,6 +660,7 @@ uninstall-am: uninstall-info-am uninstal
|
|
distclean-libtool distclean-tags distdir dvi dvi-am html \
|
|
html-am info info-am install install-am install-data \
|
|
install-data-am install-data-local install-exec \
|
|
+ install-exec-local \
|
|
install-exec-am install-info install-info-am install-man \
|
|
install-strip install-toolexeclibLTLIBRARIES installcheck \
|
|
installcheck-am installdirs maintainer-clean \
|
|
@@ -760,6 +761,13 @@ build_debug: stamp-debug
|
|
install_debug:
|
|
(cd ${debugdir} && $(MAKE) \
|
|
toolexeclibdir=$(glibcxx_toolexeclibdir)/debug install)
|
|
+
|
|
+install-exec-local:
|
|
+ifeq ($(enable_shared),yes)
|
|
+ $(AR) cru libstdc++_pic.a *.o $(top_builddir)/libsupc++/*.o
|
|
+ $(INSTALL_DATA) libstdc++_pic.a $(DESTDIR)$(toolexeclibdir)
|
|
+endif
|
|
+
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
|
.NOEXPORT:
|