mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 22:44:39 +02:00
543491d603
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24345 3c298f89-4303-0410-b956-a3cf2f4a3e73
93 lines
3.0 KiB
Diff
93 lines
3.0 KiB
Diff
--- a/configure
|
|
+++ b/configure
|
|
@@ -10917,75 +10917,7 @@ $as_echo "no" >&6; }
|
|
fi
|
|
fi
|
|
|
|
-pkg_failed=no
|
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libnfnetlink" >&5
|
|
-$as_echo_n "checking for libnfnetlink... " >&6; }
|
|
-
|
|
-if test -n "$libnfnetlink_CFLAGS"; then
|
|
- pkg_cv_libnfnetlink_CFLAGS="$libnfnetlink_CFLAGS"
|
|
- elif test -n "$PKG_CONFIG"; then
|
|
- if test -n "$PKG_CONFIG" && \
|
|
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnfnetlink >= 1.0\""; } >&5
|
|
- ($PKG_CONFIG --exists --print-errors "libnfnetlink >= 1.0") 2>&5
|
|
- ac_status=$?
|
|
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
|
- test $ac_status = 0; }; then
|
|
- pkg_cv_libnfnetlink_CFLAGS=`$PKG_CONFIG --cflags "libnfnetlink >= 1.0" 2>/dev/null`
|
|
-else
|
|
- pkg_failed=yes
|
|
-fi
|
|
- else
|
|
- pkg_failed=untried
|
|
-fi
|
|
-if test -n "$libnfnetlink_LIBS"; then
|
|
- pkg_cv_libnfnetlink_LIBS="$libnfnetlink_LIBS"
|
|
- elif test -n "$PKG_CONFIG"; then
|
|
- if test -n "$PKG_CONFIG" && \
|
|
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnfnetlink >= 1.0\""; } >&5
|
|
- ($PKG_CONFIG --exists --print-errors "libnfnetlink >= 1.0") 2>&5
|
|
- ac_status=$?
|
|
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
|
|
- test $ac_status = 0; }; then
|
|
- pkg_cv_libnfnetlink_LIBS=`$PKG_CONFIG --libs "libnfnetlink >= 1.0" 2>/dev/null`
|
|
-else
|
|
- pkg_failed=yes
|
|
-fi
|
|
- else
|
|
- pkg_failed=untried
|
|
-fi
|
|
-
|
|
-
|
|
-
|
|
-if test $pkg_failed = yes; then
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
-$as_echo "no" >&6; }
|
|
-
|
|
-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
|
|
- _pkg_short_errors_supported=yes
|
|
-else
|
|
- _pkg_short_errors_supported=no
|
|
-fi
|
|
- if test $_pkg_short_errors_supported = yes; then
|
|
- libnfnetlink_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "libnfnetlink >= 1.0" 2>&1`
|
|
- else
|
|
- libnfnetlink_PKG_ERRORS=`$PKG_CONFIG --print-errors "libnfnetlink >= 1.0" 2>&1`
|
|
- fi
|
|
- # Put the nasty error message in config.log where it belongs
|
|
- echo "$libnfnetlink_PKG_ERRORS" >&5
|
|
-
|
|
- nfnetlink=0
|
|
-elif test $pkg_failed = untried; then
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
|
-$as_echo "no" >&6; }
|
|
- nfnetlink=0
|
|
-else
|
|
- libnfnetlink_CFLAGS=$pkg_cv_libnfnetlink_CFLAGS
|
|
- libnfnetlink_LIBS=$pkg_cv_libnfnetlink_LIBS
|
|
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
|
-$as_echo "yes" >&6; }
|
|
- nfnetlink=1
|
|
-fi
|
|
- if test "$nfnetlink" = 1; then
|
|
+if false; then
|
|
HAVE_LIBNFNETLINK_TRUE=
|
|
HAVE_LIBNFNETLINK_FALSE='#'
|
|
else
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -79,9 +79,7 @@ AM_CONDITIONAL([ENABLE_LARGEFILE], [test
|
|
AM_CONDITIONAL([ENABLE_DEVEL], [test "$enable_devel" = "yes"])
|
|
AM_CONDITIONAL([ENABLE_LIBIPQ], [test "$enable_libipq" = "yes"])
|
|
|
|
-PKG_CHECK_MODULES([libnfnetlink], [libnfnetlink >= 1.0],
|
|
- [nfnetlink=1], [nfnetlink=0])
|
|
-AM_CONDITIONAL([HAVE_LIBNFNETLINK], [test "$nfnetlink" = 1])
|
|
+AM_CONDITIONAL([HAVE_LIBNFNETLINK], [false])
|
|
|
|
regular_CFLAGS="${largefile_cflags} \
|
|
-D_REENTRANT -Wall -Waggregate-return -Wmissing-declarations \
|