mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 20:22:48 +02:00
efe0e0af7d
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11195 3c298f89-4303-0410-b956-a3cf2f4a3e73
43 lines
1.6 KiB
Diff
43 lines
1.6 KiB
Diff
Index: linux-2.6.22.19/drivers/mtd/devices/at91_dataflash.c
|
|
===================================================================
|
|
--- linux-2.6.22.19.orig/drivers/mtd/devices/at91_dataflash.c
|
|
+++ linux-2.6.22.19/drivers/mtd/devices/at91_dataflash.c
|
|
@@ -173,7 +173,7 @@ static struct mtd_partition static_parti
|
|
};
|
|
#endif
|
|
|
|
-static const char *part_probes[] = { "cmdlinepart", NULL, };
|
|
+static const char *part_probes[] = { "cmdlinepart", "at91part", NULL, };
|
|
|
|
#endif
|
|
|
|
Index: linux-2.6.22.19/drivers/mtd/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.22.19.orig/drivers/mtd/Kconfig
|
|
+++ linux-2.6.22.19/drivers/mtd/Kconfig
|
|
@@ -160,6 +160,12 @@ config MTD_AFS_PARTS
|
|
for your particular device. It won't happen automatically. The
|
|
'armflash' map driver (CONFIG_MTD_ARMFLASH) does this, for example.
|
|
|
|
+config MTD_AT91_PARTS
|
|
+ tristate "Atmel AT91 partitioning support"
|
|
+ depends on MTD_PARTITIONS && ARCH_AT91RM9200 && AT91_SPI
|
|
+ ---help---
|
|
+ Atmel AT91 partitioning support
|
|
+
|
|
comment "User Modules And Translation Layers"
|
|
|
|
config MTD_CHAR
|
|
Index: linux-2.6.22.19/drivers/mtd/Makefile
|
|
===================================================================
|
|
--- linux-2.6.22.19.orig/drivers/mtd/Makefile
|
|
+++ linux-2.6.22.19/drivers/mtd/Makefile
|
|
@@ -11,6 +11,7 @@ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
|
|
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
|
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|
|
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
+obj-$(CONFIG_MTD_AT91_PARTS) += at91part.o
|
|
|
|
# 'Users' - code which presents functionality to userspace.
|
|
obj-$(CONFIG_MTD_CHAR) += mtdchar.o
|