1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 22:06:47 +03:00
openwrt-xburst/package/mac80211/patches/299-compat_minstrel.patch
nbd 8ddac8e3cd add the new compat-wireless for 2.6.27 + multi-rate retry and minstrel patches, rename patches/ for old compat-wireless to patches-old/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12865 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-10-06 12:04:04 +00:00

33 lines
968 B
Diff

--- a/config.mk
+++ b/config.mk
@@ -47,8 +47,9 @@
endif # build check
endif # kernel Makefile check
-CONFIG_MAC80211_RC_DEFAULT=pid
+CONFIG_MAC80211_RC_DEFAULT=minstrel
CONFIG_MAC80211_RC_PID=y
+CONFIG_MAC80211_RC_MINSTREL=y
# enable mesh networking too
CONFIG_MAC80211_MESH=y
--- a/include/linux/compat_autoconf.h
+++ b/include/linux/compat_autoconf.h
@@ -18,11 +18,14 @@
#define CONFIG_MAC80211 1
#endif /* CONFIG_MAC80211 */
#ifndef CONFIG_MAC80211_RC_DEFAULT
-#define CONFIG_MAC80211_RC_DEFAULT "pid"
-#endif /* CONFIG_MAC80211_RC_DEFAULT */
+#define CONFIG_MAC80211_RC_DEFAULT "minstrel"
+#endif /* CONFIG_MAC80211_RC_DEFAULT */
#ifndef CONFIG_MAC80211_RC_PID
#define CONFIG_MAC80211_RC_PID 1
#endif /* CONFIG_MAC80211_RC_PID */
+#ifndef CONFIG_MAC80211_RC_MINSTREL
+#define CONFIG_MAC80211_RC_MINSTREL 1
+#endif /* CONFIG_MAC80211_RC_MINSTREL */
#ifndef CONFIG_MAC80211_MESH
#define CONFIG_MAC80211_MESH 1
#endif /* CONFIG_MAC80211_MESH */