1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-05 05:05:08 +03:00
openwrt-xburst/tools/quilt/patches/100-patch_2.6.1_version.patch
jow ac6cfcb956 [PATCH] quilt: fix building with dash
`test x == x` gives a syntax error with dash (standard in Debian).
The modified patch reflects the current upstream:
http://git.savannah.gnu.org/cgit/quilt.git/commit/?id=38df0b210c3df67f3e784af92232ae1946b98ecd


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26804 3c298f89-4303-0410-b956-a3cf2f4a3e73
2011-05-02 12:53:32 +00:00

16 lines
400 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -274,7 +274,11 @@ fi
AC_MSG_CHECKING([the version of $PATCH])
if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
set -- `$PATCH --version 2> /dev/null`
- patch_version=$2
+ if test x$1 = xGNU ; then
+ patch_version=$3
+ else
+ patch_version=$2
+ fi
AC_MSG_RESULT($patch_version)
saved_IFS=$IFS; IFS='.'
set -- $patch_version