mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 01:29:21 +02:00
dd21551c84
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26647 3c298f89-4303-0410-b956-a3cf2f4a3e73
23 lines
832 B
Diff
23 lines
832 B
Diff
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -457,4 +457,12 @@ config LEDS_TRIGGER_USBDEV
|
|
This allows LEDs to be controlled by the presence/activity of
|
|
an USB device. If unsure, say N.
|
|
|
|
+config LEDS_TRIGGER_ADM5120_SWITCH
|
|
+ tristate "LED ADM5120 Switch Port Status Trigger"
|
|
+ depends on LEDS_TRIGGERS && ADM5120
|
|
+ help
|
|
+ This allows LEDs to be controlled by the port states of
|
|
+ the ADM5120 built-in Ethernet Switch
|
|
+ If unsure, say N.
|
|
+
|
|
endif # NEW_LEDS
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -55,3 +55,4 @@ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) +=
|
|
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
|
|
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o
|