mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 21:20:37 +02:00
e0b80e41eb
Tested on the following boards: ALFA AP96 TL-MR3220 v1 TL-WR1043ND v1 TL-WR2543ND v1 TL-WR703N v1 TL-WR741ND v1 TL-WR741ND v4 WNDR3700 v1 WZR-HP-G300NH git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29868 3c298f89-4303-0410-b956-a3cf2f4a3e73
27 lines
924 B
Diff
27 lines
924 B
Diff
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -441,6 +441,13 @@ config SPI_TLE62X0
|
|
sysfs interface, with each line presented as a kind of GPIO
|
|
exposing both switch control and diagnostic feedback.
|
|
|
|
+config SPI_RB4XX_CPLD
|
|
+ tristate "MikroTik RB4XX CPLD driver"
|
|
+ depends on ATH79_MACH_RB4XX
|
|
+ help
|
|
+ SPI driver for the Xilinx CPLD chip present on the
|
|
+ MikroTik RB4xx boards.
|
|
+
|
|
#
|
|
# Add new SPI protocol masters in alphabetical order above this line
|
|
#
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -46,6 +46,7 @@ obj-$(CONFIG_SPI_PPC4xx) += spi-ppc4xx.
|
|
obj-$(CONFIG_SPI_PXA2XX) += spi-pxa2xx.o
|
|
obj-$(CONFIG_SPI_PXA2XX_PCI) += spi-pxa2xx-pci.o
|
|
obj-$(CONFIG_SPI_RB4XX) += spi-rb4xx.o
|
|
+obj-$(CONFIG_SPI_RB4XX_CPLD) += spi-rb4xx-cpld.o
|
|
obj-$(CONFIG_SPI_S3C24XX) += spi-s3c24xx-hw.o
|
|
spi-s3c24xx-hw-y := spi-s3c24xx.o
|
|
spi-s3c24xx-hw-$(CONFIG_SPI_S3C24XX_FIQ) += spi-s3c24xx-fiq.o
|