1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 02:47:37 +03:00
openwrt-xburst/target/linux/uml/patches-3.0/004-fix_atomic64_32.patch
nico 90143b9cd2 target/uml: export atomic64_* functions on 32-bit x86
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29287 3c298f89-4303-0410-b956-a3cf2f4a3e73
2011-11-21 14:28:33 +00:00

14 lines
437 B
Diff

[patch] um: export atomic64_* functions on i386
--- a/arch/um/sys-i386/Makefile
+++ b/arch/um/sys-i386/Makefile
@@ -8,7 +8,7 @@ obj-y = bug.o bugs.o checksum.o delay.o
obj-$(CONFIG_BINFMT_ELF) += elfcore.o
-subarch-obj-y = lib/semaphore_32.o lib/string_32.o
+subarch-obj-y = lib/atomic64_32.o lib/semaphore_32.o lib/string_32.o
subarch-obj-$(CONFIG_HIGHMEM) += mm/highmem_32.o
subarch-obj-$(CONFIG_MODULES) += kernel/module.o