1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-15 17:20:03 +03:00
openwrt-xburst/tools/mkimage/patches/040-include_order.patch
nbd ecbec42440 tools/mkimage: avoid picking up unrelated /usr/include headers with the same name as internal header files (e.g. image.h), fixes #12232
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33519 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-09-23 08:49:34 +00:00

15 lines
498 B
Diff

--- a/tools/Makefile
+++ b/tools/Makefile
@@ -159,9 +159,9 @@ NOPEDOBJS := $(addprefix $(obj),$(NOPED_
# Use native tools and options
# Define __KERNEL_STRICT_NAMES to prevent typedef overlaps
#
-HOSTCPPFLAGS = -idirafter $(SRCTREE)/include \
+HOSTCPPFLAGS = -I $(SRCTREE)/include \
-idirafter $(OBJTREE)/include2 \
- -idirafter $(OBJTREE)/include \
+ -I $(OBJTREE)/include \
-I $(SRCTREE)/lib/libfdt \
-I $(SRCTREE)/tools \
-DCONFIG_SYS_TEXT_BASE=$(CONFIG_SYS_TEXT_BASE) \