1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-19 01:47:07 +03:00
openwrt-xburst/target/linux/atheros/patches-2.6.25/110-spiflash.patch
juhosg 7331aafb13 [atheros] add .25 patches (kernel boots fine on LS2, LS5, FON2200 and on WRT55AG v2)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11016 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-03 05:43:29 +00:00

25 lines
977 B
Diff

Index: linux-2.6.25.1/drivers/mtd/devices/Kconfig
===================================================================
--- linux-2.6.25.1.orig/drivers/mtd/devices/Kconfig
+++ linux-2.6.25.1/drivers/mtd/devices/Kconfig
@@ -77,6 +77,10 @@ config MTD_M25P80
if you want to specify device partitioning or to use a device which
doesn't support the JEDEC ID instruction.
+config MTD_SPIFLASH
+ tristate "Atheros AR2315/6/7 SPI Flash support"
+ depends on ATHEROS_AR5315
+
config MTD_SLRAM
tristate "Uncached system RAM"
help
Index: linux-2.6.25.1/drivers/mtd/devices/Makefile
===================================================================
--- linux-2.6.25.1.orig/drivers/mtd/devices/Makefile
+++ linux-2.6.25.1/drivers/mtd/devices/Makefile
@@ -17,3 +17,4 @@ obj-$(CONFIG_MTD_LART) += lart.o
obj-$(CONFIG_MTD_BLOCK2MTD) += block2mtd.o
obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o
obj-$(CONFIG_MTD_M25P80) += m25p80.o
+obj-$(CONFIG_MTD_SPIFLASH) += spiflash.o