mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 20:06:14 +02:00
da1bd2aad6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27310 3c298f89-4303-0410-b956-a3cf2f4a3e73
27 lines
849 B
Diff
27 lines
849 B
Diff
--- a/drivers/gpio/Kconfig
|
|
+++ b/drivers/gpio/Kconfig
|
|
@@ -419,4 +419,13 @@ config AB8500_GPIO
|
|
depends on AB8500_CORE && BROKEN
|
|
help
|
|
Select this to enable the AB8500 IC GPIO driver
|
|
+
|
|
+comment "Other GPIO expanders"
|
|
+
|
|
+config GPIO_NXP_74HC153
|
|
+ tristate "NXP 74HC153 Dual 4-input multiplexer"
|
|
+ help
|
|
+ Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
|
|
+ provides a GPIO interface supporting input mode only.
|
|
+
|
|
endif
|
|
--- a/drivers/gpio/Makefile
|
|
+++ b/drivers/gpio/Makefile
|
|
@@ -18,6 +18,7 @@ obj-$(CONFIG_GPIO_MAX7301) += max7301.o
|
|
obj-$(CONFIG_GPIO_MAX732X) += max732x.o
|
|
obj-$(CONFIG_GPIO_MC33880) += mc33880.o
|
|
obj-$(CONFIG_GPIO_MCP23S08) += mcp23s08.o
|
|
+obj-$(CONFIG_GPIO_NXP_74HC153) += nxp_74hc153.o
|
|
obj-$(CONFIG_GPIO_74X164) += 74x164.o
|
|
obj-$(CONFIG_GPIO_PCA953X) += pca953x.o
|
|
obj-$(CONFIG_GPIO_PCF857X) += pcf857x.o
|