mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-05 12:59:43 +02:00
81b3eea3b6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2048 3c298f89-4303-0410-b956-a3cf2f4a3e73
30 lines
803 B
Diff
30 lines
803 B
Diff
diff -ruN iptraf-2.7.0-old/support/Makefile iptraf-2.7.0-new/support/Makefile
|
|
--- iptraf-2.7.0-old/support/Makefile 2001-11-27 09:37:11.000000000 +0100
|
|
+++ iptraf-2.7.0-new/support/Makefile 2005-10-03 18:40:40.000000000 +0200
|
|
@@ -3,16 +3,21 @@
|
|
OBJS = input.o menurt.o listbox.o winops.o labels.o \
|
|
msgboxes.o
|
|
|
|
+AR=ar
|
|
+CC=cc
|
|
+RANLIB=ranlib
|
|
+CFLAGS= -O2 -g -fPIC
|
|
+
|
|
all: libtextbox.a
|
|
|
|
libtextbox.a: $(OBJS)
|
|
rm -rf libtextbox.a
|
|
- ar cq libtextbox.a $(OBJS)
|
|
- ranlib libtextbox.a
|
|
-# gcc -shared -o libtextbox.so $(OBJS)
|
|
+ $(AR) cq libtextbox.a $(OBJS)
|
|
+ $(RANLIB) libtextbox.a
|
|
+# $(CC) -shared -o libtextbox.so $(OBJS)
|
|
|
|
%.o: %.c *.h
|
|
- gcc -O2 -g -Wall -fPIC $(INCLUDEDIR) -c -o $*.o $<
|
|
+ $(CC) $(CFLAGS) -Wall $(INCLUDEDIR) -c -o $*.o $<
|
|
|
|
clean:
|
|
rm -rf *.o *~ libtextbox.a libtextbox.so
|