1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-19 23:00:14 +03:00
openwrt-xburst/package/hostapd/patches/001-cross_compile_fix.patch
nico 7af4d79491 update hostapd to latest development release (v0.4.5),
add driver for hostap, 
enable wpa-psk.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2276 3c298f89-4303-0410-b956-a3cf2f4a3e73
2005-10-23 13:16:37 +00:00

22 lines
630 B
Diff

diff -ruN hostapd-0.3.9-old/Makefile hostapd-0.3.9-new/Makefile
--- hostapd-0.3.9-old/Makefile 2005-06-11 05:03:36.000000000 +0200
+++ hostapd-0.3.9-new/Makefile 2005-08-14 08:09:52.000000000 +0200
@@ -3,7 +3,7 @@
DIR_HOSTAP=.
ifndef CFLAGS
-CFLAGS = -MMD -O2 -Wall -g
+CFLAGS = -MMD $(OPTFLAGS) $(CPPFLAGS)
endif
# define HOSTAPD_DUMP_STATE to include SIGUSR1 handler for dumping state to
@@ -173,7 +173,7 @@
for i in $(ALL); do cp $$i /usr/local/bin/$$i; done
hostapd: $(OBJS)
- $(CC) -o hostapd $(OBJS) $(LIBS)
+ $(CC) -o hostapd $(OBJS) $(LDFLAGS) $(LIBS)
driver_conf.c: Makefile .config
rm -f driver_conf.c