mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 23:04:05 +02:00
5cae7371a7
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32463 3c298f89-4303-0410-b956-a3cf2f4a3e73
33 lines
1.0 KiB
Diff
33 lines
1.0 KiB
Diff
build: Move optimization flags into a separate variable
|
|
|
|
Isolate optimization related compiler flags from CFLAGS and move them into a
|
|
separate COPTS variable so that it is easier to override optimizations from
|
|
the environment.
|
|
|
|
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
|
|
|
|
--- a/pppd/plugins/radius/Makefile.linux
|
|
+++ b/pppd/plugins/radius/Makefile.linux
|
|
@@ -12,7 +12,8 @@ VERSION = $(shell awk -F '"' '/VERSION/
|
|
INSTALL = install
|
|
|
|
PLUGIN=radius.so radattr.so radrealms.so
|
|
-CFLAGS=-I. -I../.. -I../../../include -O2 -fPIC -DRC_LOG_FACILITY=LOG_DAEMON
|
|
+COPTS = -O2
|
|
+CFLAGS=-I. -I../.. -I../../../include $(COPTS) -fPIC -DRC_LOG_FACILITY=LOG_DAEMON
|
|
|
|
# Uncomment the next line to include support for Microsoft's
|
|
# MS-CHAP authentication protocol.
|
|
--- a/pppdump/Makefile.linux
|
|
+++ b/pppdump/Makefile.linux
|
|
@@ -2,7 +2,8 @@ DESTDIR = $(INSTROOT)@DESTDIR@
|
|
BINDIR = $(DESTDIR)/sbin
|
|
MANDIR = $(DESTDIR)/share/man/man8
|
|
|
|
-CFLAGS= -O -I../include/net
|
|
+COPTS = -O
|
|
+CFLAGS= $(COPTS) -I../include/net
|
|
OBJS = pppdump.o bsd-comp.o deflate.o zlib.o
|
|
|
|
INSTALL= install
|