mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 13:19:42 +02:00
e979362991
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15251 3c298f89-4303-0410-b956-a3cf2f4a3e73
31 lines
1.1 KiB
Diff
31 lines
1.1 KiB
Diff
--- a/drivers/input/misc/Kconfig
|
|
+++ b/drivers/input/misc/Kconfig
|
|
@@ -227,4 +227,20 @@ config INPUT_PCF50633_PMU
|
|
Say Y to include support for delivering PMU events via input
|
|
layer on NXP PCF50633.
|
|
|
|
+config INPUT_GPIO_BUTTONS
|
|
+ tristate "Polled GPIO buttons interface"
|
|
+ depends on GENERIC_GPIO
|
|
+ select INPUT_POLLDEV
|
|
+ help
|
|
+ This driver implements support for buttons connected
|
|
+ to GPIO pins of various CPUs (and some other chips).
|
|
+
|
|
+ Say Y here if your device has buttons connected
|
|
+ directly to such GPIO pins. Your board-specific
|
|
+ setup logic must also provide a platform device,
|
|
+ with configuration data saying which GPIOs are used.
|
|
+
|
|
+ To compile this driver as a module, choose M here: the
|
|
+ module will be called gpio-buttons.
|
|
+
|
|
endif
|
|
--- a/drivers/input/misc/Makefile
|
|
+++ b/drivers/input/misc/Makefile
|
|
@@ -22,3 +22,4 @@ obj-$(CONFIG_INPUT_UINPUT) += uinput.o
|
|
obj-$(CONFIG_INPUT_APANEL) += apanel.o
|
|
obj-$(CONFIG_INPUT_SGI_BTNS) += sgi_btns.o
|
|
obj-$(CONFIG_INPUT_PCF50633_PMU) += pcf50633-input.o
|
|
+obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o
|