1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-22 15:34:37 +03:00
openwrt-xburst/target/linux/ar71xx/patches-2.6.39/112-mtd-tp-link-partition-parser.patch
juhosg 17c2fb2fc8 ar71xx: add mtd partition parser for the TP-Link boards
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29415 3c298f89-4303-0410-b956-a3cf2f4a3e73
2011-12-03 18:13:27 +00:00

26 lines
855 B
Diff

--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
@@ -198,6 +198,12 @@ config MTD_MYLOADER_PARTS
You will still need the parsing functions to be called by the driver
for your particular device. It won't happen automatically.
+config MTD_TPLINK_PARTS
+ tristate "TP-Link AR7XXX/AR9XXX partitioning support"
+ depends on MTD_PARTITIONS && ATHEROS_AR71XX
+ ---help---
+ TBD.
+
comment "User Modules And Translation Layers"
config MTD_CHAR
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
@@ -14,6 +14,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
obj-$(CONFIG_MTD_WRT160NL_PARTS) += wrt160nl_part.o
obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
+obj-$(CONFIG_MTD_TPLINK_PARTS) += tplinkpart.o
# 'Users' - code which presents functionality to userspace.
obj-$(CONFIG_MTD_CHAR) += mtdchar.o