1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-22 01:12:26 +03:00
openwrt-xburst/target/linux/generic/patches-2.6.31/402-ledtrig_netdev.patch
hauke 70befa4020 kernel: use tab in front of ledtrig-netdev.o and refresh kernel
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24798 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-12-22 17:18:11 +00:00

22 lines
707 B
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -301,4 +301,11 @@ config LEDS_TRIGGER_MORSE
tristate "LED Morse Trigger"
depends on LEDS_TRIGGERS
+config LEDS_TRIGGER_NETDEV
+ tristate "LED Netdev Trigger"
+ depends on NET && LEDS_TRIGGERS
+ help
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -40,3 +40,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o