1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-21 23:08:59 +03:00
openwrt-xburst/target/linux/generic/patches-2.6.36/012-extra_optimization.patch
acoul b74489d910 linux/generic: refresh 2.6.36 kernel patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23237 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-10-05 08:50:54 +00:00

22 lines
592 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -537,7 +537,7 @@ all: vmlinux
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
KBUILD_CFLAGS += -Os
else
-KBUILD_CFLAGS += -O2
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
endif
include $(srctree)/arch/$(SRCARCH)/Makefile
@@ -579,6 +579,9 @@ endif
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)