1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-21 23:42:05 +03:00
openwrt-xburst/target/linux/generic/patches-2.6.36/403-ledtrig-usbdev.patch
hauke 70befa4020 kernel: use tab in front of ledtrig-netdev.o and refresh kernel
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24798 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-12-22 17:18:11 +00:00

22 lines
761 B
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -391,4 +391,11 @@ config LEDS_TRIGGER_NETDEV
This allows LEDs to be controlled by network device activity.
If unsure, say Y.
+config LEDS_TRIGGER_USBDEV
+ tristate "LED USB device Trigger"
+ depends on USB && LEDS_TRIGGERS
+ help
+ This allows LEDs to be controlled by the presence/activity of
+ an USB device. If unsure, say N.
+
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -51,3 +51,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o