1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 03:30:14 +03:00
openwrt-xburst/target/linux/amcc-2.6/patches/120-uncompressed_uImage.patch
kaloz 0f31d464c4 add support for the AMCC Taishan, mark it as broken until we fix the combined layout
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7377 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-05-28 16:47:42 +00:00

18 lines
733 B
Diff

diff -Nur linux-2.6.21/arch/ppc/boot/images/Makefile linux-2.6.21-owrt/arch/ppc/boot/images/Makefile
--- linux-2.6.21/arch/ppc/boot/images/Makefile 2007-04-27 23:49:26.000000000 +0200
+++ linux-2.6.21-owrt/arch/ppc/boot/images/Makefile 2007-05-28 17:44:11.000000000 +0200
@@ -20,11 +20,11 @@
quiet_cmd_uimage = UIMAGE $@
cmd_uimage = $(CONFIG_SHELL) $(MKIMAGE) -A ppc -O linux -T kernel \
- -C gzip -a 00000000 -e 00000000 -n 'Linux-$(KERNELRELEASE)' \
+ -C none -a 00000000 -e 00000000 -n 'Linux-$(KERNELRELEASE)' \
-d $< $@
targets += uImage
-$(obj)/uImage: $(obj)/vmlinux.gz
+$(obj)/uImage: $(obj)/vmlinux.bin
$(Q)rm -f $@
$(call cmd,uimage)
@echo -n ' Image: $@ '