1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 00:48:04 +03:00
openwrt-xburst/target/linux/rb532-2.6/patches/120-cf.patch
nbd 0771c0af36 convert rb532 to the new structure
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7273 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-05-19 13:14:38 +00:00

27 lines
957 B
Diff

diff -urN linux.old/drivers/block/Kconfig linux.dev/drivers/block/Kconfig
--- linux.old/drivers/block/Kconfig 2006-10-26 02:43:39.000000000 +0200
+++ linux.dev/drivers/block/Kconfig 2006-10-26 00:11:14.000000000 +0200
@@ -456,4 +456,12 @@
This driver provides Support for ATA over Ethernet block
devices like the Coraid EtherDrive (R) Storage Blade.
+config BLK_DEV_CF_MIPS
+ bool "CF slot of RB532 board"
+ depends on MIKROTIK_RB500
+ default y
+ help
+ The Routerboard 532 has a CF slot on it. Enable the special block
+ device driver for it.
+
endmenu
diff -urN linux.old/drivers/block/Makefile linux.dev/drivers/block/Makefile
--- linux.old/drivers/block/Makefile 2006-06-18 03:49:35.000000000 +0200
+++ linux.dev/drivers/block/Makefile 2006-10-26 02:44:10.000000000 +0200
@@ -29,4 +29,5 @@
obj-$(CONFIG_VIODASD) += viodasd.o
obj-$(CONFIG_BLK_DEV_SX8) += sx8.o
obj-$(CONFIG_BLK_DEV_UB) += ub.o
+obj-$(CONFIG_BLK_DEV_CF_MIPS) += rb500/