1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 17:50:14 +03:00
openwrt-xburst/target/linux/uml/patches-2.6.34/001-gcc4_unit_at_a_time_i386_fix.patch
florian 30932c53d3 [uml] add 2.6.34 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20208 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-03-14 17:20:45 +00:00

12 lines
556 B
Diff

--- a/arch/um/Makefile-i386
+++ b/arch/um/Makefile-i386
@@ -35,7 +35,7 @@ cflags-y += -ffreestanding
# Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
# a lot more stack due to the lack of sharing of stacklots. Also, gcc
# 4.3.0 needs -funit-at-a-time for extern inline functions.
-KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
+KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0403 ] ; then \
echo $(call cc-option,-fno-unit-at-a-time); \
else echo $(call cc-option,-funit-at-a-time); fi ;)