mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 21:52:28 +02:00
b5cb1795de
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7490 3c298f89-4303-0410-b956-a3cf2f4a3e73
589 lines
21 KiB
Diff
589 lines
21 KiB
Diff
Index: keynote-2.3/configure
|
|
===================================================================
|
|
--- keynote-2.3.orig/configure 2007-06-04 13:22:41.259582872 +0200
|
|
+++ keynote-2.3/configure 2007-06-04 13:22:41.658522224 +0200
|
|
@@ -889,52 +889,10 @@
|
|
done
|
|
test -n "$YACC" || YACC="yacc"
|
|
|
|
-for ac_prog in openssl ssleay
|
|
-do
|
|
-# Extract the first word of "$ac_prog", so it can be a program name with args.
|
|
-set dummy $ac_prog; ac_word=$2
|
|
-echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
|
|
-echo "configure:898: checking for $ac_word" >&5
|
|
-if eval "test \"`echo '$''{'ac_cv_path_SSLEAY'+set}'`\" = set"; then
|
|
- echo $ac_n "(cached) $ac_c" 1>&6
|
|
-else
|
|
- case "$SSLEAY" in
|
|
- /*)
|
|
- ac_cv_path_SSLEAY="$SSLEAY" # Let the user override the test with a path.
|
|
- ;;
|
|
- ?:/*)
|
|
- ac_cv_path_SSLEAY="$SSLEAY" # Let the user override the test with a dos path.
|
|
- ;;
|
|
- *)
|
|
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
|
|
- ac_dummy="\
|
|
- $PATH:/usr/local/bin:/usr/local/ssl/sbin:/usr/local/ssl/bin:/usr/ssl/bin:/usr/ssl/sbin:/usr/sbin:/usr/openssl/bin:/usr/openssl/bin:/usr/local/openssl/bin:/usr/local/openssl/sbin"
|
|
- for ac_dir in $ac_dummy; do
|
|
- test -z "$ac_dir" && ac_dir=.
|
|
- if test -f $ac_dir/$ac_word; then
|
|
- ac_cv_path_SSLEAY="$ac_dir/$ac_word"
|
|
- break
|
|
- fi
|
|
- done
|
|
- IFS="$ac_save_ifs"
|
|
- ;;
|
|
-esac
|
|
-fi
|
|
-SSLEAY="$ac_cv_path_SSLEAY"
|
|
-if test -n "$SSLEAY"; then
|
|
- echo "$ac_t""$SSLEAY" 1>&6
|
|
-else
|
|
- echo "$ac_t""no" 1>&6
|
|
-fi
|
|
-
|
|
-test -n "$SSLEAY" && break
|
|
-done
|
|
-test -n "$SSLEAY" || SSLEAY="/usr/local/bin/ssleay"
|
|
-
|
|
# Extract the first word of "rm", so it can be a program name with args.
|
|
set dummy rm; ac_word=$2
|
|
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
|
|
-echo "configure:938: checking for $ac_word" >&5
|
|
+echo "configure:896: checking for $ac_word" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_path_RM'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
@@ -970,7 +928,7 @@
|
|
# Extract the first word of "ar", so it can be a program name with args.
|
|
set dummy ar; ac_word=$2
|
|
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
|
|
-echo "configure:974: checking for $ac_word" >&5
|
|
+echo "configure:932: checking for $ac_word" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_path_AR'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
@@ -1006,7 +964,7 @@
|
|
# Extract the first word of "nroff", so it can be a program name with args.
|
|
set dummy nroff; ac_word=$2
|
|
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
|
|
-echo "configure:1010: checking for $ac_word" >&5
|
|
+echo "configure:968: checking for $ac_word" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_path_NROFF'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
@@ -1042,7 +1000,7 @@
|
|
# Extract the first word of "tar", so it can be a program name with args.
|
|
set dummy tar; ac_word=$2
|
|
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
|
|
-echo "configure:1046: checking for $ac_word" >&5
|
|
+echo "configure:1004: checking for $ac_word" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_path_TAR'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
@@ -1078,7 +1036,7 @@
|
|
# Extract the first word of "true", so it can be a program name with args.
|
|
set dummy true; ac_word=$2
|
|
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
|
|
-echo "configure:1082: checking for $ac_word" >&5
|
|
+echo "configure:1040: checking for $ac_word" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_path_TRUE'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
@@ -1114,7 +1072,7 @@
|
|
# Extract the first word of "mkdir", so it can be a program name with args.
|
|
set dummy mkdir; ac_word=$2
|
|
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
|
|
-echo "configure:1118: checking for $ac_word" >&5
|
|
+echo "configure:1076: checking for $ac_word" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_path_MKDIR'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
@@ -1150,7 +1108,7 @@
|
|
# Extract the first word of "tr", so it can be a program name with args.
|
|
set dummy tr; ac_word=$2
|
|
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
|
|
-echo "configure:1154: checking for $ac_word" >&5
|
|
+echo "configure:1112: checking for $ac_word" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_path_TR'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
@@ -1186,7 +1144,7 @@
|
|
# Extract the first word of "echo", so it can be a program name with args.
|
|
set dummy echo; ac_word=$2
|
|
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
|
|
-echo "configure:1190: checking for $ac_word" >&5
|
|
+echo "configure:1148: checking for $ac_word" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_path_ECHO'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
@@ -1222,7 +1180,7 @@
|
|
# Extract the first word of "sed", so it can be a program name with args.
|
|
set dummy sed; ac_word=$2
|
|
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
|
|
-echo "configure:1226: checking for $ac_word" >&5
|
|
+echo "configure:1184: checking for $ac_word" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_path_SED'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
@@ -1256,11 +1214,8 @@
|
|
fi
|
|
|
|
|
|
-LIBS="-L/usr/lib -L/usr/local/lib -L/usr/ssl/lib -L/usr/openssl/lib\
|
|
- -L/usr/local/ssl/lib -L/usr/local/openssl/lib -L/usr/pkg/lib -L/pkg/lib"
|
|
-
|
|
echo $ac_n "checking for floor in -lm""... $ac_c" 1>&6
|
|
-echo "configure:1264: checking for floor in -lm" >&5
|
|
+echo "configure:1219: checking for floor in -lm" >&5
|
|
ac_lib_var=`echo m'_'floor | sed 'y%./+-%__p_%'`
|
|
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
@@ -1268,7 +1223,7 @@
|
|
ac_save_LIBS="$LIBS"
|
|
LIBS="-lm $LIBS"
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1272 "configure"
|
|
+#line 1227 "configure"
|
|
#include "confdefs.h"
|
|
/* Override any gcc2 internal prototype to avoid an error. */
|
|
/* We use char because int might match the return type of a gcc2
|
|
@@ -1279,7 +1234,7 @@
|
|
floor()
|
|
; return 0; }
|
|
EOF
|
|
-if { (eval echo configure:1283: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
|
+if { (eval echo configure:1238: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
|
rm -rf conftest*
|
|
eval "ac_cv_lib_$ac_lib_var=yes"
|
|
else
|
|
@@ -1300,7 +1255,7 @@
|
|
fi
|
|
|
|
echo $ac_n "checking for RSAPrivateDecrypt in -lrsaref""... $ac_c" 1>&6
|
|
-echo "configure:1304: checking for RSAPrivateDecrypt in -lrsaref" >&5
|
|
+echo "configure:1259: checking for RSAPrivateDecrypt in -lrsaref" >&5
|
|
ac_lib_var=`echo rsaref'_'RSAPrivateDecrypt | sed 'y%./+-%__p_%'`
|
|
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
@@ -1308,7 +1263,7 @@
|
|
ac_save_LIBS="$LIBS"
|
|
LIBS="-lrsaref $LIBS"
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1312 "configure"
|
|
+#line 1267 "configure"
|
|
#include "confdefs.h"
|
|
/* Override any gcc2 internal prototype to avoid an error. */
|
|
/* We use char because int might match the return type of a gcc2
|
|
@@ -1319,7 +1274,7 @@
|
|
RSAPrivateDecrypt()
|
|
; return 0; }
|
|
EOF
|
|
-if { (eval echo configure:1323: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
|
+if { (eval echo configure:1278: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
|
rm -rf conftest*
|
|
eval "ac_cv_lib_$ac_lib_var=yes"
|
|
else
|
|
@@ -1340,7 +1295,7 @@
|
|
fi
|
|
|
|
echo $ac_n "checking for i2a_ASN1_STRING in -lcrypto""... $ac_c" 1>&6
|
|
-echo "configure:1344: checking for i2a_ASN1_STRING in -lcrypto" >&5
|
|
+echo "configure:1299: checking for i2a_ASN1_STRING in -lcrypto" >&5
|
|
ac_lib_var=`echo crypto'_'i2a_ASN1_STRING | sed 'y%./+-%__p_%'`
|
|
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
@@ -1348,7 +1303,7 @@
|
|
ac_save_LIBS="$LIBS"
|
|
LIBS="-lcrypto $LIBS"
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1352 "configure"
|
|
+#line 1307 "configure"
|
|
#include "confdefs.h"
|
|
/* Override any gcc2 internal prototype to avoid an error. */
|
|
/* We use char because int might match the return type of a gcc2
|
|
@@ -1359,7 +1314,7 @@
|
|
i2a_ASN1_STRING()
|
|
; return 0; }
|
|
EOF
|
|
-if { (eval echo configure:1363: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
|
+if { (eval echo configure:1318: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
|
rm -rf conftest*
|
|
eval "ac_cv_lib_$ac_lib_var=yes"
|
|
else
|
|
@@ -1380,7 +1335,7 @@
|
|
fi
|
|
|
|
echo $ac_n "checking for RSA_ref_private_encrypt in -lRSAglue""... $ac_c" 1>&6
|
|
-echo "configure:1384: checking for RSA_ref_private_encrypt in -lRSAglue" >&5
|
|
+echo "configure:1339: checking for RSA_ref_private_encrypt in -lRSAglue" >&5
|
|
ac_lib_var=`echo RSAglue'_'RSA_ref_private_encrypt | sed 'y%./+-%__p_%'`
|
|
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
@@ -1388,7 +1343,7 @@
|
|
ac_save_LIBS="$LIBS"
|
|
LIBS="-lRSAglue $LIBS"
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1392 "configure"
|
|
+#line 1347 "configure"
|
|
#include "confdefs.h"
|
|
/* Override any gcc2 internal prototype to avoid an error. */
|
|
/* We use char because int might match the return type of a gcc2
|
|
@@ -1399,7 +1354,7 @@
|
|
RSA_ref_private_encrypt()
|
|
; return 0; }
|
|
EOF
|
|
-if { (eval echo configure:1403: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
|
+if { (eval echo configure:1358: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
|
rm -rf conftest*
|
|
eval "ac_cv_lib_$ac_lib_var=yes"
|
|
else
|
|
@@ -1420,12 +1375,9 @@
|
|
fi
|
|
|
|
|
|
-CPPFLAGS="-I/usr/include -I/usr/local/include -I/usr/ssl/include\
|
|
- -I/usr/local/ssl/include -I/usr/openssl/include -I/usr/pkg/include\
|
|
- -I/usr/local/openssl/include -I/pkg/include"
|
|
|
|
echo $ac_n "checking how to run the C preprocessor""... $ac_c" 1>&6
|
|
-echo "configure:1429: checking how to run the C preprocessor" >&5
|
|
+echo "configure:1381: checking how to run the C preprocessor" >&5
|
|
# On Suns, sometimes $CPP names a directory.
|
|
if test -n "$CPP" && test -d "$CPP"; then
|
|
CPP=
|
|
@@ -1440,13 +1392,13 @@
|
|
# On the NeXT, cc -E runs the code through the compiler's parser,
|
|
# not just through cpp.
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1444 "configure"
|
|
+#line 1396 "configure"
|
|
#include "confdefs.h"
|
|
#include <assert.h>
|
|
Syntax Error
|
|
EOF
|
|
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
|
|
-{ (eval echo configure:1450: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
|
+{ (eval echo configure:1402: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
|
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
|
|
if test -z "$ac_err"; then
|
|
:
|
|
@@ -1457,13 +1409,13 @@
|
|
rm -rf conftest*
|
|
CPP="${CC-cc} -E -traditional-cpp"
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1461 "configure"
|
|
+#line 1413 "configure"
|
|
#include "confdefs.h"
|
|
#include <assert.h>
|
|
Syntax Error
|
|
EOF
|
|
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
|
|
-{ (eval echo configure:1467: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
|
+{ (eval echo configure:1419: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
|
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
|
|
if test -z "$ac_err"; then
|
|
:
|
|
@@ -1474,13 +1426,13 @@
|
|
rm -rf conftest*
|
|
CPP="${CC-cc} -nologo -E"
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1478 "configure"
|
|
+#line 1430 "configure"
|
|
#include "confdefs.h"
|
|
#include <assert.h>
|
|
Syntax Error
|
|
EOF
|
|
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
|
|
-{ (eval echo configure:1484: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
|
+{ (eval echo configure:1436: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
|
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
|
|
if test -z "$ac_err"; then
|
|
:
|
|
@@ -1505,12 +1457,12 @@
|
|
echo "$ac_t""$CPP" 1>&6
|
|
|
|
echo $ac_n "checking for ANSI C header files""... $ac_c" 1>&6
|
|
-echo "configure:1509: checking for ANSI C header files" >&5
|
|
+echo "configure:1461: checking for ANSI C header files" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_header_stdc'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1514 "configure"
|
|
+#line 1466 "configure"
|
|
#include "confdefs.h"
|
|
#include <stdlib.h>
|
|
#include <stdarg.h>
|
|
@@ -1518,7 +1470,7 @@
|
|
#include <float.h>
|
|
EOF
|
|
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
|
|
-{ (eval echo configure:1522: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
|
+{ (eval echo configure:1474: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
|
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
|
|
if test -z "$ac_err"; then
|
|
rm -rf conftest*
|
|
@@ -1535,7 +1487,7 @@
|
|
if test $ac_cv_header_stdc = yes; then
|
|
# SunOS 4.x string.h does not declare mem*, contrary to ANSI.
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1539 "configure"
|
|
+#line 1491 "configure"
|
|
#include "confdefs.h"
|
|
#include <string.h>
|
|
EOF
|
|
@@ -1553,7 +1505,7 @@
|
|
if test $ac_cv_header_stdc = yes; then
|
|
# ISC 2.0.2 stdlib.h does not declare free, contrary to ANSI.
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1557 "configure"
|
|
+#line 1509 "configure"
|
|
#include "confdefs.h"
|
|
#include <stdlib.h>
|
|
EOF
|
|
@@ -1574,7 +1526,7 @@
|
|
:
|
|
else
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1578 "configure"
|
|
+#line 1530 "configure"
|
|
#include "confdefs.h"
|
|
#include <ctype.h>
|
|
#define ISLOWER(c) ('a' <= (c) && (c) <= 'z')
|
|
@@ -1585,7 +1537,7 @@
|
|
exit (0); }
|
|
|
|
EOF
|
|
-if { (eval echo configure:1589: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
|
|
+if { (eval echo configure:1541: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
|
|
then
|
|
:
|
|
else
|
|
@@ -1609,12 +1561,12 @@
|
|
fi
|
|
|
|
echo $ac_n "checking whether time.h and sys/time.h may both be included""... $ac_c" 1>&6
|
|
-echo "configure:1613: checking whether time.h and sys/time.h may both be included" >&5
|
|
+echo "configure:1565: checking whether time.h and sys/time.h may both be included" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_header_time'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1618 "configure"
|
|
+#line 1570 "configure"
|
|
#include "confdefs.h"
|
|
#include <sys/types.h>
|
|
#include <sys/time.h>
|
|
@@ -1623,7 +1575,7 @@
|
|
struct tm *tp;
|
|
; return 0; }
|
|
EOF
|
|
-if { (eval echo configure:1627: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
|
|
+if { (eval echo configure:1579: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
|
|
rm -rf conftest*
|
|
ac_cv_header_time=yes
|
|
else
|
|
@@ -1647,17 +1599,17 @@
|
|
do
|
|
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
|
|
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
|
|
-echo "configure:1651: checking for $ac_hdr" >&5
|
|
+echo "configure:1603: checking for $ac_hdr" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1656 "configure"
|
|
+#line 1608 "configure"
|
|
#include "confdefs.h"
|
|
#include <$ac_hdr>
|
|
EOF
|
|
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
|
|
-{ (eval echo configure:1661: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
|
+{ (eval echo configure:1613: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
|
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
|
|
if test -z "$ac_err"; then
|
|
rm -rf conftest*
|
|
@@ -1687,17 +1639,17 @@
|
|
do
|
|
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
|
|
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
|
|
-echo "configure:1691: checking for $ac_hdr" >&5
|
|
+echo "configure:1643: checking for $ac_hdr" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1696 "configure"
|
|
+#line 1648 "configure"
|
|
#include "confdefs.h"
|
|
#include <$ac_hdr>
|
|
EOF
|
|
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
|
|
-{ (eval echo configure:1701: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
|
+{ (eval echo configure:1653: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
|
|
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
|
|
if test -z "$ac_err"; then
|
|
rm -rf conftest*
|
|
@@ -1726,12 +1678,12 @@
|
|
|
|
|
|
echo $ac_n "checking for working const""... $ac_c" 1>&6
|
|
-echo "configure:1730: checking for working const" >&5
|
|
+echo "configure:1682: checking for working const" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_c_const'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1735 "configure"
|
|
+#line 1687 "configure"
|
|
#include "confdefs.h"
|
|
|
|
int main() {
|
|
@@ -1780,7 +1732,7 @@
|
|
|
|
; return 0; }
|
|
EOF
|
|
-if { (eval echo configure:1784: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
|
|
+if { (eval echo configure:1736: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
|
|
rm -rf conftest*
|
|
ac_cv_c_const=yes
|
|
else
|
|
@@ -1801,12 +1753,12 @@
|
|
fi
|
|
|
|
echo $ac_n "checking for u_int""... $ac_c" 1>&6
|
|
-echo "configure:1805: checking for u_int" >&5
|
|
+echo "configure:1757: checking for u_int" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_type_u_int'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1810 "configure"
|
|
+#line 1762 "configure"
|
|
#include "confdefs.h"
|
|
#include <sys/types.h>
|
|
#if STDC_HEADERS
|
|
@@ -1834,12 +1786,12 @@
|
|
fi
|
|
|
|
echo $ac_n "checking for u_char""... $ac_c" 1>&6
|
|
-echo "configure:1838: checking for u_char" >&5
|
|
+echo "configure:1790: checking for u_char" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_type_u_char'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1843 "configure"
|
|
+#line 1795 "configure"
|
|
#include "confdefs.h"
|
|
#include <sys/types.h>
|
|
#if STDC_HEADERS
|
|
@@ -1870,12 +1822,12 @@
|
|
for ac_func in regcomp open close read _open _close _read strchr memcpy
|
|
do
|
|
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
|
|
-echo "configure:1874: checking for $ac_func" >&5
|
|
+echo "configure:1826: checking for $ac_func" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1879 "configure"
|
|
+#line 1831 "configure"
|
|
#include "confdefs.h"
|
|
/* System header to define __stub macros and hopefully few prototypes,
|
|
which can conflict with char $ac_func(); below. */
|
|
@@ -1898,7 +1850,7 @@
|
|
|
|
; return 0; }
|
|
EOF
|
|
-if { (eval echo configure:1902: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
|
+if { (eval echo configure:1854: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
|
rm -rf conftest*
|
|
eval "ac_cv_func_$ac_func=yes"
|
|
else
|
|
@@ -1925,12 +1877,12 @@
|
|
for ac_func in strcasecmp strncasecmp stricmp strnicmp snprintf __b64_ntop
|
|
do
|
|
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
|
|
-echo "configure:1929: checking for $ac_func" >&5
|
|
+echo "configure:1881: checking for $ac_func" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1934 "configure"
|
|
+#line 1886 "configure"
|
|
#include "confdefs.h"
|
|
/* System header to define __stub macros and hopefully few prototypes,
|
|
which can conflict with char $ac_func(); below. */
|
|
@@ -1953,7 +1905,7 @@
|
|
|
|
; return 0; }
|
|
EOF
|
|
-if { (eval echo configure:1957: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
|
+if { (eval echo configure:1909: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
|
rm -rf conftest*
|
|
eval "ac_cv_func_$ac_func=yes"
|
|
else
|
|
@@ -1980,12 +1932,12 @@
|
|
for ac_func in getopt
|
|
do
|
|
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
|
|
-echo "configure:1984: checking for $ac_func" >&5
|
|
+echo "configure:1936: checking for $ac_func" >&5
|
|
if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
cat > conftest.$ac_ext <<EOF
|
|
-#line 1989 "configure"
|
|
+#line 1941 "configure"
|
|
#include "confdefs.h"
|
|
/* System header to define __stub macros and hopefully few prototypes,
|
|
which can conflict with char $ac_func(); below. */
|
|
@@ -2008,7 +1960,7 @@
|
|
|
|
; return 0; }
|
|
EOF
|
|
-if { (eval echo configure:2012: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
|
+if { (eval echo configure:1964: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
|
rm -rf conftest*
|
|
eval "ac_cv_func_$ac_func=yes"
|
|
else
|
|
@@ -2172,7 +2124,6 @@
|
|
s%@CC@%$CC%g
|
|
s%@RANLIB@%$RANLIB%g
|
|
s%@YACC@%$YACC%g
|
|
-s%@SSLEAY@%$SSLEAY%g
|
|
s%@RM@%$RM%g
|
|
s%@AR@%$AR%g
|
|
s%@NROFF@%$NROFF%g
|
|
Index: keynote-2.3/configure.in
|
|
===================================================================
|
|
--- keynote-2.3.orig/configure.in 2007-06-04 13:22:41.389563112 +0200
|
|
+++ keynote-2.3/configure.in 2007-06-04 13:22:41.658522224 +0200
|
|
@@ -9,8 +9,8 @@
|
|
AC_PROG_CC
|
|
AC_PROG_RANLIB
|
|
AC_PROG_YACC
|
|
-AC_PATH_PROGS(SSLEAY, openssl ssleay, /usr/local/bin/ssleay, \
|
|
- $PATH:/usr/local/bin:/usr/local/ssl/sbin:/usr/local/ssl/bin:/usr/ssl/bin:/usr/ssl/sbin:/usr/sbin:/usr/openssl/bin:/usr/openssl/bin:/usr/local/openssl/bin:/usr/local/openssl/sbin)
|
|
+dnl AC_PATH_PROGS(SSLEAY, openssl ssleay, /usr/local/bin/ssleay, \
|
|
+dnl $PATH:/usr/local/bin:/usr/local/ssl/sbin:/usr/local/ssl/bin:/usr/ssl/bin:/usr/ssl/sbin:/usr/sbin:/usr/openssl/bin:/usr/openssl/bin:/usr/local/openssl/bin:/usr/local/openssl/sbin)
|
|
AC_PATH_PROG(RM, rm, /bin/rm)
|
|
AC_PATH_PROG(AR, ar, /usr/bin/ar)
|
|
AC_PATH_PROG(NROFF, nroff, /usr/bin/nroff)
|
|
@@ -27,7 +27,7 @@
|
|
AC_CHECK_LIB(RSAglue, RSA_ref_private_encrypt, LIBS="$LIBS -lRSAglue")
|
|
|
|
dnl Checks for header files.
|
|
-CPPFLAGS="-I/usr/include/openssl"
|
|
+dnl CPPFLAGS="-I/usr/include/openssl"
|
|
|
|
AC_HEADER_STDC
|
|
AC_HEADER_TIME
|