1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-18 05:19:53 +03:00
openwrt-xburst/package/broadcom-wl/patches/002-ctype.patch
jow db7c7e9e4d [package] broadcom-wl:
- fix compilation against eglibc and glibc (#7521)
	- unbind device from b43 ssb bridge on boot (#7529)


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22007 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-07-01 01:06:32 +00:00

31 lines
622 B
Diff

--- a/shared/Makefile
+++ b/shared/Makefile
@@ -19,7 +19,7 @@ LDFLAGS += -L.
AR=ar
RANLIB=ranlib
-OBJS := shutils.o wl.o wl_linux.o linux_timer.o
+OBJS := shutils.o wl.o wl_linux.o linux_timer.o ctype.o
all: libshared.a
clean:
--- /dev/null
+++ b/shared/ctype.c
@@ -0,0 +1,16 @@
+#include <features.h>
+
+#ifndef __UCLIBC__
+extern void **__ctype_b_loc();
+extern void **__ctype_tolower_loc();
+
+void *__ctype_b;
+void *__ctype_tolower;
+
+static void init(void) __attribute__((constructor));
+static void init(void)
+{
+ __ctype_b = *__ctype_b_loc();
+ __ctype_tolower = *__ctype_tolower_loc();
+}
+#endif