mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 14:25:20 +02:00
666d09a548
Split makefile patch into multiple patches, Add no-gtk fix from whiterussian. git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1402 3c298f89-4303-0410-b956-a3cf2f4a3e73
34 lines
925 B
Diff
34 lines
925 B
Diff
diff -ruN asterisk-1.0.7-old/channels/h323/Makefile asterisk-1.0.7-new/channels/h323/Makefile
|
|
--- asterisk-1.0.7-old/channels/h323/Makefile 2004-11-15 03:35:35.000000000 +0100
|
|
+++ asterisk-1.0.7-new/channels/h323/Makefile 2005-03-19 17:38:06.000000000 +0100
|
|
@@ -22,9 +22,11 @@
|
|
OSARCH=$(shell uname -s)
|
|
ifneq (${OSARCH},FreeBSD)
|
|
ifneq (${OSARCH},NetBSD)
|
|
+ifneq ($(PROC),mipsel)
|
|
CFLAGS += -march=$(shell uname -m)
|
|
endif
|
|
endif
|
|
+endif
|
|
CFLAGS += -DPBYTE_ORDER=PLITTLE_ENDIAN
|
|
|
|
ifeq (${OSARCH},Linux)
|
|
@@ -47,7 +49,7 @@
|
|
|
|
# Pre Janus release directives
|
|
CFLAGS += -DNDEBUG -DDO_CRASH -DDEBUG_THREADS
|
|
-CFLAGS += -pipe -Wall -fPIC
|
|
+CFLAGS += -pipe -Wall -fPIC $(OPTIMIZE)
|
|
ifeq (${OSARCH},Linux)
|
|
CFLAGS += -DP_LINUX
|
|
LIBS+=-lpthread
|
|
@@ -74,7 +76,7 @@
|
|
|
|
|
|
libchanh323.a: ast_h323.o
|
|
- ar cr libchanh323.a ast_h323.o
|
|
+ $(AR) cr libchanh323.a ast_h323.o
|
|
|
|
ast_h323.o: ast_h323.cpp
|
|
$(CXX) -g -c -fno-rtti -o $@ $(CFLAGS) $<
|