mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 19:25:20 +02:00
7c5041e32c
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3381 3c298f89-4303-0410-b956-a3cf2f4a3e73
99 lines
3.4 KiB
Diff
99 lines
3.4 KiB
Diff
Only in mgetty-1.1.31: .prepared
|
|
diff -ur mgetty-1.1.31-old/Makefile mgetty-1.1.31/Makefile
|
|
--- mgetty-1.1.31-old/Makefile 2006-01-02 00:37:56.000000000 +0000
|
|
+++ mgetty-1.1.31/Makefile 2006-01-02 00:43:57.000000000 +0000
|
|
@@ -164,7 +164,9 @@
|
|
#
|
|
# if your systems doesn't have one, use the shell script that I provide
|
|
# in "inst.sh" (taken from X11R5). Needed on IRIX5.2
|
|
-INSTALL=install -c -o bin -g bin
|
|
+STRIP=$(STAGING_DIR)sstrip
|
|
+INSTALL=install -c -o root -g root
|
|
+#INSTALL=install -c -o bin -g bin
|
|
#INSTALL=install -c -o root -g wheel # NeXT/BSD
|
|
#INSTALL=/usr/ucb/install -c -o bin -g bin # AIX, Solaris 2.x
|
|
#INSTALL=installbsd -c -o bin -g bin # OSF/1, AIX 4.1, 4.2
|
|
@@ -216,7 +218,7 @@
|
|
# (it's possible to run faxrunq(d) as root, but the FAX_OUT_USER
|
|
# MUST NOT BE root or any other privileged account).
|
|
#
|
|
-FAX_OUT_USER=fax
|
|
+FAX_OUT_USER=root
|
|
#
|
|
#
|
|
# Where section 1 manual pages should be placed
|
|
@@ -416,7 +418,12 @@
|
|
./mksed >sedscript
|
|
chmod 700 sedscript
|
|
|
|
-mksed: mksed.c policy.h Makefile
|
|
+REALGCC:=/usr/bin/gcc
|
|
+mksed: mksed.c policy.h Makefile
|
|
+ ( echo $(REALGCC); $(MAKE) "CC=$(REALGCC)" "CFLAGS=$(CFLAGS)" mksed-wrong;\
|
|
+ );
|
|
+
|
|
+mksed-wrong: mksed.c policy.h Makefile
|
|
$(CC) $(CFLAGS) -DBINDIR=\"$(BINDIR)\" -DSBINDIR=\"$(SBINDIR)\" \
|
|
-DLIBDIR=\"$(LIBDIR)\" \
|
|
-DCONFDIR=\"$(CONFDIR)\" \
|
|
@@ -590,8 +597,10 @@
|
|
-test -d $(SBINDIR) || ( ./mkidirs $(SBINDIR) ; chmod 755 $(SBINDIR) )
|
|
-mv -f $(SBINDIR)/mgetty $(SBINDIR)/mgetty.old
|
|
-mv -f $(SBINDIR)/sendfax $(SBINDIR)/sendfax.old
|
|
- $(INSTALL) -s -m 700 mgetty $(SBINDIR)
|
|
- $(INSTALL) -s -m 755 sendfax $(SBINDIR)
|
|
+ $(INSTALL) -m 700 mgetty $(SBINDIR)
|
|
+ $(STRIP) $(SBINDIR)/mgetty
|
|
+ $(INSTALL) -m 755 sendfax $(SBINDIR)
|
|
+ $(STRIP) $(SBINDIR)/sendfax
|
|
#
|
|
# data files + directories
|
|
#
|
|
@@ -653,7 +662,8 @@
|
|
if [ ! -z "$(INSTALL_MECHO)" ] ; then \
|
|
cd compat ; \
|
|
$(CC) $(CFLAGS) -o mg.echo mg.echo.c && \
|
|
- $(INSTALL) -s -m 755 mg.echo $(BINDIR) ; \
|
|
+ $(INSTALL) -m 755 mg.echo $(BINDIR) && \
|
|
+ $(STRIP) $(BINDIR)/mg.echo ; \
|
|
fi
|
|
|
|
#
|
|
Only in mgetty-1.1.31-old: Makefile.orig
|
|
Only in mgetty-1.1.31-old: Makefile.rej
|
|
diff -ur mgetty-1.1.31-old/g3/Makefile mgetty-1.1.31/g3/Makefile
|
|
--- mgetty-1.1.31-old/g3/Makefile 2006-01-02 00:37:56.000000000 +0000
|
|
+++ mgetty-1.1.31/g3/Makefile 2006-01-02 00:42:17.000000000 +0000
|
|
@@ -40,7 +40,8 @@
|
|
# install programs
|
|
#
|
|
for f in $(G3_PROGRAMS) ; do \
|
|
- $(INSTALL) -s -m 755 $$f $(BINDIR) ; \
|
|
+ $(INSTALL) -m 755 $$f $(BINDIR) ; \
|
|
+ $(STRIP) $(BINDIR)/$$f ; \
|
|
done
|
|
#
|
|
# make symlink for "g3topbm" (so third-party fax viewers won't fail)
|
|
diff -ur mgetty-1.1.31-old/logfile.c mgetty-1.1.31/logfile.c
|
|
--- mgetty-1.1.31-old/logfile.c 2006-01-02 00:37:56.000000000 +0000
|
|
+++ mgetty-1.1.31/logfile.c 2006-01-02 00:42:17.000000000 +0000
|
|
@@ -327,12 +327,11 @@
|
|
}
|
|
else /* ERROR or FATAL */
|
|
{
|
|
- fprintf(log_fp, "\n%02d/%02d %02d:%02d:%02d %s %s: %s",
|
|
+ fprintf(log_fp, "\n%02d/%02d %02d:%02d:%02d %s %s: #%d",
|
|
tm->tm_mon+1, tm->tm_mday,
|
|
tm->tm_hour, tm->tm_min, tm->tm_sec,
|
|
log_infix, ws,
|
|
- ( errnr <= sys_nerr ) ? sys_errlist[errnr]:
|
|
- "<error not in list>" );
|
|
+ errnr );
|
|
#ifdef SYSLOG
|
|
syslog( level == L_FATAL? LOG_ALERT: LOG_ERR, "%s: %m", ws );
|
|
#endif
|
|
Only in mgetty-1.1.31-old/voice/libutil: access.c.orig
|
|
Only in mgetty-1.1.31-old/voice/libvoice: Lucent.c.orig
|
|
Only in mgetty-1.1.31-old/voice/libvoice: V253modem.c.orig
|
|
Only in mgetty-1.1.31-old/voice/pvftools: pvftormd.c.orig
|