mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 01:27:32 +02:00
4d4c41d673
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26692 3c298f89-4303-0410-b956-a3cf2f4a3e73
28 lines
800 B
Diff
28 lines
800 B
Diff
--- a/drivers/char/Kconfig
|
|
+++ b/drivers/char/Kconfig
|
|
@@ -1047,6 +1047,14 @@ config CS5535_GPIO
|
|
|
|
If compiled as a module, it will be called cs5535_gpio.
|
|
|
|
+config GPIO_DEVICE
|
|
+ tristate "GPIO device support"
|
|
+ depends on GENERIC_GPIO
|
|
+ help
|
|
+ Say Y to enable Linux GPIO device support. This allows control of
|
|
+ GPIO pins using a character device
|
|
+
|
|
+
|
|
config RAW_DRIVER
|
|
tristate "RAW driver (/dev/raw/rawN)"
|
|
depends on BLOCK
|
|
--- a/drivers/char/Makefile
|
|
+++ b/drivers/char/Makefile
|
|
@@ -82,6 +82,7 @@ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio
|
|
obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
|
|
obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o
|
|
obj-$(CONFIG_CS5535_GPIO) += cs5535_gpio.o
|
|
+obj-$(CONFIG_GPIO_DEVICE) += gpio_dev.o
|
|
obj-$(CONFIG_GPIO_TB0219) += tb0219.o
|
|
obj-$(CONFIG_TELCLOCK) += tlclk.o
|
|
|