mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 19:40:16 +02:00
03e726c2ae
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31131 3c298f89-4303-0410-b956-a3cf2f4a3e73
67 lines
2.0 KiB
Diff
67 lines
2.0 KiB
Diff
From cfcc8526e97bdcbfcbf945246b878262389b8842 Mon Sep 17 00:00:00 2001
|
|
From: Florian Fainelli <florian@openwrt.org>
|
|
Date: Wed, 25 Jan 2012 17:39:59 +0100
|
|
Subject: [PATCH 17/63] MIPS: BCM63XX: add RNG driver platform_device stub
|
|
|
|
Signed-off-by: Florian Fainelli <florian@openwrt.org>
|
|
---
|
|
arch/mips/bcm63xx/Makefile | 4 ++--
|
|
arch/mips/bcm63xx/dev-trng.c | 40 ++++++++++++++++++++++++++++++++++++++++
|
|
2 files changed, 42 insertions(+), 2 deletions(-)
|
|
create mode 100644 arch/mips/bcm63xx/dev-trng.c
|
|
|
|
--- a/arch/mips/bcm63xx/Makefile
|
|
+++ b/arch/mips/bcm63xx/Makefile
|
|
@@ -1,6 +1,6 @@
|
|
obj-y += clk.o cpu.o cs.o gpio.o irq.o prom.o setup.o timer.o \
|
|
- dev-dsp.o dev-enet.o dev-pcmcia.o dev-spi.o dev-uart.o \
|
|
- dev-wdt.o
|
|
+ dev-dsp.o dev-enet.o dev-pcmcia.o dev-spi.o dev-trng.o \
|
|
+ dev-uart.o dev-wdt.o
|
|
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
|
|
|
|
obj-y += boards/
|
|
--- /dev/null
|
|
+++ b/arch/mips/bcm63xx/dev-trng.c
|
|
@@ -0,0 +1,40 @@
|
|
+/*
|
|
+ * This file is subject to the terms and conditions of the GNU General Public
|
|
+ * License. See the file "COPYING" in the main directory of this archive
|
|
+ * for more details.
|
|
+ *
|
|
+ * Copyright (C) 2011 Florian Fainelli <florian@openwrt.org>
|
|
+ */
|
|
+
|
|
+#include <linux/init.h>
|
|
+#include <linux/kernel.h>
|
|
+#include <linux/platform_device.h>
|
|
+#include <bcm63xx_cpu.h>
|
|
+
|
|
+static struct resource trng_resources[] = {
|
|
+ {
|
|
+ .start = -1, /* filled at runtime */
|
|
+ .end = -1, /* filled at runtime */
|
|
+ .flags = IORESOURCE_MEM,
|
|
+ },
|
|
+};
|
|
+
|
|
+static struct platform_device bcm63xx_trng_device = {
|
|
+ .name = "bcm63xx-trng",
|
|
+ .id = -1,
|
|
+ .num_resources = ARRAY_SIZE(trng_resources),
|
|
+ .resource = trng_resources,
|
|
+};
|
|
+
|
|
+int __init bcm63xx_trng_register(void)
|
|
+{
|
|
+ if (!BCMCPU_IS_6368())
|
|
+ return -ENODEV;
|
|
+
|
|
+ trng_resources[0].start = bcm63xx_regset_address(RSET_TRNG);
|
|
+ trng_resources[0].end = trng_resources[0].start;
|
|
+ trng_resources[0].end += RSET_TRNG_SIZE - 1;
|
|
+
|
|
+ return platform_device_register(&bcm63xx_trng_device);
|
|
+}
|
|
+arch_initcall(bcm63xx_trng_register);
|