mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 19:40:16 +02:00
295c63c334
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31924 3c298f89-4303-0410-b956-a3cf2f4a3e73
12 lines
487 B
Diff
12 lines
487 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -374,7 +374,7 @@ KBUILD_CFLAGS_KERNEL :=
|
|
KBUILD_AFLAGS := -D__ASSEMBLY__
|
|
KBUILD_AFLAGS_MODULE := -DMODULE
|
|
KBUILD_CFLAGS_MODULE := -DMODULE
|
|
-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
|
|
+KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
|
|
|
|
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
|
|
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
|