mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-06 10:43:08 +02:00
338c0960e5
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6778 3c298f89-4303-0410-b956-a3cf2f4a3e73
40 lines
1.7 KiB
Diff
40 lines
1.7 KiB
Diff
diff -urN linux-2.6.17/drivers/mtd/maps/Kconfig linux-2.6.17.new/drivers/mtd/maps/Kconfig
|
|
--- linux-2.6.17/drivers/mtd/maps/Kconfig 2006-06-18 03:49:35.000000000 +0200
|
|
+++ linux-2.6.17.new/drivers/mtd/maps/Kconfig 2006-09-24 20:28:11.000000000 +0200
|
|
@@ -76,6 +76,12 @@
|
|
PNC-2000 is the name of Network Camera product from PHOTRON
|
|
Ltd. in Japan. It uses CFI-compliant flash.
|
|
|
|
+config MTD_RDC3210
|
|
+ tristate "CFI Flash device mapped on RDC3210"
|
|
+ depends on X86 && MTD_CFI && MTD_PARTITIONS
|
|
+ help
|
|
+ RDC-3210 is the flash device we find on Ralink reference board
|
|
+
|
|
config MTD_SC520CDP
|
|
tristate "CFI Flash device mapped on AMD SC520 CDP"
|
|
depends on X86 && MTD_CFI
|
|
diff -urN linux-2.6.17/drivers/mtd/maps/Makefile linux-2.6.17.new/drivers/mtd/maps/Makefile
|
|
--- linux-2.6.17/drivers/mtd/maps/Makefile 2006-06-18 03:49:35.000000000 +0200
|
|
+++ linux-2.6.17.new/drivers/mtd/maps/Makefile 2006-09-24 20:26:10.000000000 +0200
|
|
@@ -28,6 +28,7 @@
|
|
obj-$(CONFIG_MTD_PHYSMAP) += physmap.o
|
|
obj-$(CONFIG_MTD_PNC2000) += pnc2000.o
|
|
obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
|
|
+obj-$(CONFIG_MTD_RDC3210) += rdc3210.o
|
|
obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
|
|
obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
|
|
obj-$(CONFIG_MTD_SA1100) += sa1100-flash.o
|
|
diff -urN linux-2.6.19/drivers/mtd/redboot.c linux-2.6.19.new/drivers/mtd/redboot.c
|
|
--- linux-2.6.19/drivers/mtd/redboot.c 2006-12-18 17:09:14.000000000 +0100
|
|
+++ linux-2.6.19.new/drivers/mtd/redboot.c 2006-12-18 17:14:26.000000000 +0100
|
|
@@ -39,7 +39,7 @@
|
|
return 1;
|
|
}
|
|
|
|
-static int parse_redboot_partitions(struct mtd_info *master,
|
|
+int parse_redboot_partitions(struct mtd_info *master,
|
|
struct mtd_partition **pparts,
|
|
unsigned long fis_origin)
|
|
{
|