1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 12:01:09 +03:00
openwrt-xburst/target/linux/brcm47xx/patches-2.6.25/110-flash_map.patch
juhosg 17bba1a8f6 [brcm47xx] refresh kernel patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11200 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-19 08:08:23 +00:00

30 lines
1.2 KiB
Diff

Index: linux-2.6.25.4/drivers/mtd/maps/Kconfig
===================================================================
--- linux-2.6.25.4.orig/drivers/mtd/maps/Kconfig
+++ linux-2.6.25.4/drivers/mtd/maps/Kconfig
@@ -337,6 +337,12 @@ config MTD_CFI_FLAGADM
Mapping for the Flaga digital module. If you don't have one, ignore
this setting.
+config MTD_BCM47XX
+ tristate "BCM47xx flash device"
+ depends on MIPS && MTD_CFI && BCM47XX
+ help
+ Support for the flash chips on the BCM947xx board.
+
config MTD_WALNUT
tristate "Flash device mapped on IBM 405GP Walnut"
depends on MTD_JEDECPROBE && WALNUT && !PPC_MERGE
Index: linux-2.6.25.4/drivers/mtd/maps/Makefile
===================================================================
--- linux-2.6.25.4.orig/drivers/mtd/maps/Makefile
+++ linux-2.6.25.4/drivers/mtd/maps/Makefile
@@ -31,6 +31,7 @@ obj-$(CONFIG_MTD_PMC_MSP_RAMROOT)+= pmcm
obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
+obj-$(CONFIG_MTD_BCM47XX) += bcm47xx-flash.o
obj-$(CONFIG_MTD_SA1100) += sa1100-flash.o
obj-$(CONFIG_MTD_IPAQ) += ipaq-flash.o
obj-$(CONFIG_MTD_SBC_GXX) += sbc_gxx.o