1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-17 23:35:53 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.21/010-disable_old_squashfs_compatibility.patch
nbd e0c1b38c1c rename generic-2.6/patches to generic-2.6/patches-2.6.21
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12636 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-09-21 11:25:17 +00:00

24 lines
803 B
Diff

Index: linux-2.6.21.7/fs/squashfs/Makefile
===================================================================
--- linux-2.6.21.7.orig/fs/squashfs/Makefile
+++ linux-2.6.21.7/fs/squashfs/Makefile
@@ -4,4 +4,3 @@
obj-$(CONFIG_SQUASHFS) += squashfs.o
squashfs-y += inode.o
-squashfs-y += squashfs2_0.o
Index: linux-2.6.21.7/fs/squashfs/squashfs.h
===================================================================
--- linux-2.6.21.7.orig/fs/squashfs/squashfs.h
+++ linux-2.6.21.7/fs/squashfs/squashfs.h
@@ -24,6 +24,9 @@
#ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#endif
+#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#endif
#ifdef SQUASHFS_TRACE
#define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)