mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 19:27:31 +02:00
86ddd45f31
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23317 3c298f89-4303-0410-b956-a3cf2f4a3e73
26 lines
854 B
Diff
26 lines
854 B
Diff
--- a/drivers/gpio/Kconfig
|
|
+++ b/drivers/gpio/Kconfig
|
|
@@ -361,4 +361,12 @@ config GPIO_JANZ_TTL
|
|
This driver provides support for driving the pins in output
|
|
mode only. Input mode is not supported.
|
|
|
|
+comment "Other GPIO expanders"
|
|
+
|
|
+config GPIO_NXP_74HC153
|
|
+ tristate "NXP 74HC153 Dual 4-input multiplexer"
|
|
+ help
|
|
+ Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
|
|
+ provides a GPIO interface supporting inputs.
|
|
+
|
|
endif
|
|
--- a/drivers/gpio/Makefile
|
|
+++ b/drivers/gpio/Makefile
|
|
@@ -17,6 +17,7 @@ obj-$(CONFIG_GPIO_MAX7301) += max7301.o
|
|
obj-$(CONFIG_GPIO_MAX732X) += max732x.o
|
|
obj-$(CONFIG_GPIO_MC33880) += mc33880.o
|
|
obj-$(CONFIG_GPIO_MCP23S08) += mcp23s08.o
|
|
+obj-$(CONFIG_GPIO_NXP_74HC153) += nxp_74hc153.o
|
|
obj-$(CONFIG_GPIO_PCA953X) += pca953x.o
|
|
obj-$(CONFIG_GPIO_PCF857X) += pcf857x.o
|
|
obj-$(CONFIG_GPIO_PL061) += pl061.o
|