1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-28 02:10:23 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.30/004-extra_optimization.patch
juhosg a452106e88 [kernel] 2.6.{28,30}: refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16934 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-07-20 10:59:21 +00:00

13 lines
365 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -567,6 +567,9 @@ endif
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)