1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 23:24:37 +03:00
openwrt-xburst/target/linux/generic/patches-2.6.35/692-phy_psb6970.patch
florian 14d155196f [kernel] add switch driver for Lantiq PSB6970
Tested on ifxmips based board. The PSB6970 is also known as the Infineon Tantos switch.

Signed-off-by: Ithamar R. Adema <ithamar.adema@team-embedded.nl>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22914 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-09-04 18:06:01 +00:00

24 lines
724 B
Diff

--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -15,6 +15,7 @@ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
obj-$(CONFIG_ICPLUS_PHY) += icplus.o
obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+obj-$(CONFIG_PSB6970_PHY) += psb6970.o
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
@@ -104,6 +104,10 @@ config ADM6996_PHY
---help---
Currently supports the ADM6996F switch
+config PSB6970_PHY
+ tristate "Driver for Lantiq PSB6970 (Tantos) switch"
+ select SWCONFIG
+
config MVSWITCH_PHY
tristate "Driver for Marvell 88E6060 switches"