mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 00:29:41 +02:00
14537ae0c6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10911 3c298f89-4303-0410-b956-a3cf2f4a3e73
241 lines
7.0 KiB
Diff
241 lines
7.0 KiB
Diff
diff -Nur linux-2.6.23/arch/arm/mach-ixp4xx/Kconfig linux-2.6.23-owrt/arch/arm/mach-ixp4xx/Kconfig
|
|
--- linux-2.6.23/arch/arm/mach-ixp4xx/Kconfig 2007-10-23 19:20:08.000000000 +0200
|
|
+++ linux-2.6.23-owrt/arch/arm/mach-ixp4xx/Kconfig 2007-10-23 19:26:46.000000000 +0200
|
|
@@ -65,6 +65,14 @@
|
|
Engineering Pronghorn Metro Platform. For more
|
|
information on this platform, see <file:Documentation/arm/IXP4xx>.
|
|
|
|
+config MACH_SIDEWINDER
|
|
+ bool "Sidewinder"
|
|
+ select PCI
|
|
+ help
|
|
+ Say 'Y' here if you want your kernel to support the ADI
|
|
+ Engineering Sidewinder Platform. For more
|
|
+ information on this platform, see <file:Documentation/arm/IXP4xx>.
|
|
+
|
|
config MACH_COMPEX
|
|
bool "Compex WP18 / NP18A"
|
|
select PCI
|
|
@@ -163,7 +171,7 @@
|
|
#
|
|
config CPU_IXP46X
|
|
bool
|
|
- depends on MACH_IXDP465
|
|
+ depends on MACH_IXDP465 || MACH_SIDEWINDER
|
|
default y
|
|
|
|
config CPU_IXP43X
|
|
diff -Nur linux-2.6.23/arch/arm/mach-ixp4xx/Makefile linux-2.6.23-owrt/arch/arm/mach-ixp4xx/Makefile
|
|
--- linux-2.6.23/arch/arm/mach-ixp4xx/Makefile 2007-10-23 19:20:08.000000000 +0200
|
|
+++ linux-2.6.23-owrt/arch/arm/mach-ixp4xx/Makefile 2007-10-23 19:23:52.000000000 +0200
|
|
@@ -19,6 +19,7 @@
|
|
obj-pci-$(CONFIG_MACH_PRONGHORNMETRO) += pronghornmetro-pci.o
|
|
obj-pci-$(CONFIG_MACH_COMPEX) += ixdp425-pci.o
|
|
obj-pci-$(CONFIG_MACH_WRT300NV2) += wrt300nv2-pci.o
|
|
+obj-pci-$(CONFIG_MACH_SIDEWINDER) += sidewinder-pci.o
|
|
|
|
obj-y += common.o
|
|
|
|
@@ -36,6 +37,7 @@
|
|
obj-$(CONFIG_MACH_PRONGHORNMETRO) += pronghornmetro-setup.o
|
|
obj-$(CONFIG_MACH_COMPEX) += compex-setup.o
|
|
obj-$(CONFIG_MACH_WRT300NV2) += wrt300nv2-setup.o
|
|
+obj-$(CONFIG_MACH_SIDEWINDER) += sidewinder-setup.o
|
|
|
|
obj-$(CONFIG_PCI) += $(obj-pci-$(CONFIG_PCI)) common-pci.o
|
|
obj-$(CONFIG_IXP4XX_QMGR) += ixp4xx_qmgr.o
|
|
diff -Nur linux-2.6.23/arch/arm/mach-ixp4xx/sidewinder-pci.c linux-2.6.23-owrt/arch/arm/mach-ixp4xx/sidewinder-pci.c
|
|
--- linux-2.6.23/arch/arm/mach-ixp4xx/sidewinder-pci.c 1970-01-01 01:00:00.000000000 +0100
|
|
+++ linux-2.6.23-owrt/arch/arm/mach-ixp4xx/sidewinder-pci.c 2007-10-23 19:23:52.000000000 +0200
|
|
@@ -0,0 +1,71 @@
|
|
+/*
|
|
+ * arch/arch/mach-ixp4xx/pronghornmetro-pci.c
|
|
+ *
|
|
+ * PCI setup routines for ADI Engineering Sidewinder
|
|
+ *
|
|
+ * Copyright (C) 2007 Imre Kaloz <kaloz@openwrt.org>
|
|
+ *
|
|
+ * based on coyote-pci.c:
|
|
+ * Copyright (C) 2002 Jungo Software Technologies.
|
|
+ * Copyright (C) 2003 MontaVista Softwrae, Inc.
|
|
+ *
|
|
+ * Maintainer: Imre Kaloz <kaloz@openwrt.org>
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or modify
|
|
+ * it under the terms of the GNU General Public License version 2 as
|
|
+ * published by the Free Software Foundation.
|
|
+ *
|
|
+ */
|
|
+
|
|
+#include <linux/kernel.h>
|
|
+#include <linux/pci.h>
|
|
+#include <linux/init.h>
|
|
+#include <linux/irq.h>
|
|
+
|
|
+#include <asm/mach-types.h>
|
|
+#include <asm/hardware.h>
|
|
+#include <asm/irq.h>
|
|
+
|
|
+#include <asm/mach/pci.h>
|
|
+
|
|
+extern void ixp4xx_pci_preinit(void);
|
|
+extern int ixp4xx_setup(int nr, struct pci_sys_data *sys);
|
|
+extern struct pci_bus *ixp4xx_scan_bus(int nr, struct pci_sys_data *sys);
|
|
+
|
|
+void __init sidewinder_pci_preinit(void)
|
|
+{
|
|
+ set_irq_type(IRQ_IXP4XX_GPIO11, IRQT_LOW);
|
|
+ set_irq_type(IRQ_IXP4XX_GPIO10, IRQT_LOW);
|
|
+ set_irq_type(IRQ_IXP4XX_GPIO9, IRQT_LOW);
|
|
+
|
|
+ ixp4xx_pci_preinit();
|
|
+}
|
|
+
|
|
+static int __init sidewinder_map_irq(struct pci_dev *dev, u8 slot, u8 pin)
|
|
+{
|
|
+ if (slot == 1)
|
|
+ return IRQ_IXP4XX_GPIO11;
|
|
+ else if (slot == 2)
|
|
+ return IRQ_IXP4XX_GPIO10;
|
|
+ else if (slot == 3)
|
|
+ return IRQ_IXP4XX_GPIO9;
|
|
+ else return -1;
|
|
+}
|
|
+
|
|
+struct hw_pci sidewinder_pci __initdata = {
|
|
+ .nr_controllers = 1,
|
|
+ .preinit = sidewinder_pci_preinit,
|
|
+ .swizzle = pci_std_swizzle,
|
|
+ .setup = ixp4xx_setup,
|
|
+ .scan = ixp4xx_scan_bus,
|
|
+ .map_irq = sidewinder_map_irq,
|
|
+};
|
|
+
|
|
+int __init sidewinder_pci_init(void)
|
|
+{
|
|
+ if (machine_is_sidewinder())
|
|
+ pci_common_init(&sidewinder_pci);
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+subsys_initcall(sidewinder_pci_init);
|
|
diff -Nur linux-2.6.23/arch/arm/mach-ixp4xx/sidewinder-setup.c linux-2.6.23-owrt/arch/arm/mach-ixp4xx/sidewinder-setup.c
|
|
--- linux-2.6.23/arch/arm/mach-ixp4xx/sidewinder-setup.c 1970-01-01 01:00:00.000000000 +0100
|
|
+++ linux-2.6.23-owrt/arch/arm/mach-ixp4xx/sidewinder-setup.c 2007-10-23 19:23:52.000000000 +0200
|
|
@@ -0,0 +1,115 @@
|
|
+/*
|
|
+ * arch/arm/mach-ixp4xx/sidewinder-setup.c
|
|
+ *
|
|
+ * Board setup for the ADI Engineering Sidewinder
|
|
+ *
|
|
+ * Copyright (C) 2007 Imre Kaloz <Kaloz@openwrt.org>
|
|
+ *
|
|
+ * based on coyote-setup.c:
|
|
+ * Copyright (C) 2003-2005 MontaVista Software, Inc.
|
|
+ *
|
|
+ * Author: Imre Kaloz <Kaloz@openwrt.org>
|
|
+ */
|
|
+
|
|
+#include <linux/kernel.h>
|
|
+#include <linux/serial.h>
|
|
+#include <linux/serial_8250.h>
|
|
+
|
|
+#include <asm/mach-types.h>
|
|
+#include <asm/mach/arch.h>
|
|
+#include <asm/mach/flash.h>
|
|
+
|
|
+static struct flash_platform_data sidewinder_flash_data = {
|
|
+ .map_name = "cfi_probe",
|
|
+ .width = 2,
|
|
+};
|
|
+
|
|
+static struct resource sidewinder_flash_resource = {
|
|
+ .flags = IORESOURCE_MEM,
|
|
+};
|
|
+
|
|
+static struct platform_device sidewinder_flash = {
|
|
+ .name = "IXP4XX-Flash",
|
|
+ .id = 0,
|
|
+ .dev = {
|
|
+ .platform_data = &sidewinder_flash_data,
|
|
+ },
|
|
+ .num_resources = 1,
|
|
+ .resource = &sidewinder_flash_resource,
|
|
+};
|
|
+
|
|
+static struct resource sidewinder_uart_resources[] = {
|
|
+ {
|
|
+ .start = IXP4XX_UART1_BASE_PHYS,
|
|
+ .end = IXP4XX_UART1_BASE_PHYS + 0x0fff,
|
|
+ .flags = IORESOURCE_MEM,
|
|
+ },
|
|
+ {
|
|
+ .start = IXP4XX_UART2_BASE_PHYS,
|
|
+ .end = IXP4XX_UART2_BASE_PHYS + 0x0fff,
|
|
+ .flags = IORESOURCE_MEM,
|
|
+ }
|
|
+};
|
|
+
|
|
+static struct plat_serial8250_port sidewinder_uart_data[] = {
|
|
+ {
|
|
+ .mapbase = IXP4XX_UART1_BASE_PHYS,
|
|
+ .membase = (char *)IXP4XX_UART1_BASE_VIRT + REG_OFFSET,
|
|
+ .irq = IRQ_IXP4XX_UART1,
|
|
+ .flags = UPF_BOOT_AUTOCONF | UPF_SKIP_TEST,
|
|
+ .iotype = UPIO_MEM,
|
|
+ .regshift = 2,
|
|
+ .uartclk = IXP4XX_UART_XTAL,
|
|
+ },
|
|
+ {
|
|
+ .mapbase = IXP4XX_UART2_BASE_PHYS,
|
|
+ .membase = (char *)IXP4XX_UART2_BASE_VIRT + REG_OFFSET,
|
|
+ .irq = IRQ_IXP4XX_UART2,
|
|
+ .flags = UPF_BOOT_AUTOCONF | UPF_SKIP_TEST,
|
|
+ .iotype = UPIO_MEM,
|
|
+ .regshift = 2,
|
|
+ .uartclk = IXP4XX_UART_XTAL,
|
|
+ },
|
|
+ { },
|
|
+};
|
|
+
|
|
+static struct platform_device sidewinder_uart = {
|
|
+ .name = "serial8250",
|
|
+ .id = PLAT8250_DEV_PLATFORM,
|
|
+ .dev = {
|
|
+ .platform_data = sidewinder_uart_data,
|
|
+ },
|
|
+ .num_resources = ARRAY_SIZE(sidewinder_uart_resources),
|
|
+ .resource = sidewinder_uart_resources,
|
|
+};
|
|
+
|
|
+static struct platform_device *sidewinder_devices[] __initdata = {
|
|
+ &sidewinder_flash,
|
|
+ &sidewinder_uart,
|
|
+};
|
|
+
|
|
+static void __init sidewinder_init(void)
|
|
+{
|
|
+ ixp4xx_sys_init();
|
|
+
|
|
+ sidewinder_flash_resource.start = IXP4XX_EXP_BUS_BASE(0);
|
|
+ sidewinder_flash_resource.end = IXP4XX_EXP_BUS_BASE(0) + SZ_64M - 1;
|
|
+
|
|
+ *IXP4XX_EXP_CS0 |= IXP4XX_FLASH_WRITABLE;
|
|
+ *IXP4XX_EXP_CS1 = *IXP4XX_EXP_CS0;
|
|
+
|
|
+ platform_add_devices(sidewinder_devices, ARRAY_SIZE(sidewinder_devices));
|
|
+}
|
|
+
|
|
+#ifdef CONFIG_MACH_SIDEWINDER
|
|
+MACHINE_START(SIDEWINDER, "ADI Engineering Sidewinder")
|
|
+ /* Maintainer: Imre Kaloz <kaloz@openwrt.org> */
|
|
+ .phys_io = IXP4XX_PERIPHERAL_BASE_PHYS,
|
|
+ .io_pg_offst = ((IXP4XX_PERIPHERAL_BASE_VIRT) >> 18) & 0xfffc,
|
|
+ .map_io = ixp4xx_map_io,
|
|
+ .init_irq = ixp4xx_init_irq,
|
|
+ .timer = &ixp4xx_timer,
|
|
+ .boot_params = 0x0100,
|
|
+ .init_machine = sidewinder_init,
|
|
+MACHINE_END
|
|
+#endif
|