mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 14:07:31 +02:00
dab3ca1324
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2877 3c298f89-4303-0410-b956-a3cf2f4a3e73
13 lines
454 B
Diff
13 lines
454 B
Diff
--- linux-2.6.12.5/Makefile.old 2005-10-23 22:56:29.017270000 +0200
|
|
+++ linux-2.6.12.5/Makefile 2005-10-23 22:57:23.226138500 +0200
|
|
@@ -533,6 +533,9 @@
|
|
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
|
|
|
+# improve gcc optimization
|
|
+CFLAGS += $(call cc-option,-funit-at-a-time,)
|
|
+
|
|
# warn about C99 declaration after statement
|
|
CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
|
|
|