mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 11:06:16 +02:00
ac02d17ea5
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10006 3c298f89-4303-0410-b956-a3cf2f4a3e73
27 lines
969 B
Diff
27 lines
969 B
Diff
Index: a/gas/config/tc-avr32.c
|
|
===================================================================
|
|
--- a/gas/config/tc-avr32.c (revision 31496)
|
|
+++ b/gas/config/tc-avr32.c (revision 32014)
|
|
@@ -3092,6 +3092,8 @@
|
|
|
|
/* Make sure the constant pool is properly aligned */
|
|
frag_align_code(2, 0);
|
|
+ if (bfd_get_section_alignment(stdoutput, pool->section) < 2)
|
|
+ bfd_set_section_alignment(stdoutput, pool->section, 2);
|
|
|
|
/* Assume none of the entries are discarded, and that we need the
|
|
maximum amount of alignment. But we're not going to allocate
|
|
Index: a/bfd/configure.in
|
|
===================================================================
|
|
--- a/bfd/configure.in (revision 31496)
|
|
+++ b/bfd/configure.in (revision 32014)
|
|
@@ -8,7 +8,7 @@
|
|
AC_CANONICAL_TARGET
|
|
AC_ISC_POSIX
|
|
|
|
-AM_INIT_AUTOMAKE(bfd, 2.17.atmel.1.2.0)
|
|
+AM_INIT_AUTOMAKE(bfd, 2.17.atmel.1.2.1)
|
|
|
|
dnl These must be called before AM_PROG_LIBTOOL, because it may want
|
|
dnl to call AC_CHECK_PROG.
|