mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 22:25:20 +02:00
cb86f32419
Add support for 2.6.39 based on rc3. Runtime tested on bcm63xx. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26615 3c298f89-4303-0410-b956-a3cf2f4a3e73
25 lines
675 B
Diff
25 lines
675 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -543,9 +543,9 @@ endif # $(dot-config)
|
|
all: vmlinux
|
|
|
|
ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
|
|
-KBUILD_CFLAGS += -Os
|
|
+KBUILD_CFLAGS += -Os -fno-caller-saves
|
|
else
|
|
-KBUILD_CFLAGS += -O2
|
|
+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
|
|
endif
|
|
|
|
include $(srctree)/arch/$(SRCARCH)/Makefile
|
|
@@ -600,6 +600,9 @@ endif
|
|
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
|
|
|
+# improve gcc optimization
|
|
+CFLAGS += $(call cc-option,-funit-at-a-time,)
|
|
+
|
|
# warn about C99 declaration after statement
|
|
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
|
|
|