mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 20:33:08 +02:00
5ae7e31f6f
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9422 3c298f89-4303-0410-b956-a3cf2f4a3e73
128 lines
4.7 KiB
Diff
128 lines
4.7 KiB
Diff
Index: madwifi-ng-r2756-20071018/ath/if_ath.c
|
|
===================================================================
|
|
--- madwifi-ng-r2756-20071018.orig/ath/if_ath.c 2007-10-24 06:20:20.213841201 +0200
|
|
+++ madwifi-ng-r2756-20071018/ath/if_ath.c 2007-10-24 06:20:20.433853739 +0200
|
|
@@ -75,7 +75,7 @@
|
|
#include <net80211/if_llc.h>
|
|
#endif
|
|
|
|
-#define AR_DEBUG
|
|
+#undef AR_DEBUG
|
|
|
|
#include "net80211/if_athproto.h"
|
|
#include "if_athvar.h"
|
|
Index: madwifi-ng-r2756-20071018/ath_rate/amrr/amrr.c
|
|
===================================================================
|
|
--- madwifi-ng-r2756-20071018.orig/ath_rate/amrr/amrr.c 2007-10-24 06:20:16.253615519 +0200
|
|
+++ madwifi-ng-r2756-20071018/ath_rate/amrr/amrr.c 2007-10-24 06:20:20.433853739 +0200
|
|
@@ -70,7 +70,7 @@
|
|
|
|
#include "amrr.h"
|
|
|
|
-#define AMRR_DEBUG
|
|
+#undef AMRR_DEBUG
|
|
#ifdef AMRR_DEBUG
|
|
#define DPRINTF(sc, _fmt, ...) do { \
|
|
if (sc->sc_debug & 0x10) \
|
|
Index: madwifi-ng-r2756-20071018/ath_rate/minstrel/minstrel.c
|
|
===================================================================
|
|
--- madwifi-ng-r2756-20071018.orig/ath_rate/minstrel/minstrel.c 2007-10-24 06:20:18.217727448 +0200
|
|
+++ madwifi-ng-r2756-20071018/ath_rate/minstrel/minstrel.c 2007-10-24 06:20:20.441854191 +0200
|
|
@@ -117,7 +117,7 @@
|
|
|
|
#include "minstrel.h"
|
|
|
|
-#define MINSTREL_DEBUG
|
|
+#undef MINSTREL_DEBUG
|
|
#ifdef MINSTREL_DEBUG
|
|
enum {
|
|
ATH_DEBUG_RATE = 0x00000010 /* rate control */
|
|
Index: madwifi-ng-r2756-20071018/ath_rate/onoe/onoe.c
|
|
===================================================================
|
|
--- madwifi-ng-r2756-20071018.orig/ath_rate/onoe/onoe.c 2007-10-24 06:20:16.269616432 +0200
|
|
+++ madwifi-ng-r2756-20071018/ath_rate/onoe/onoe.c 2007-10-24 06:20:20.445854420 +0200
|
|
@@ -66,7 +66,7 @@
|
|
|
|
#include "onoe.h"
|
|
|
|
-#define ONOE_DEBUG
|
|
+#undef ONOE_DEBUG
|
|
#ifdef ONOE_DEBUG
|
|
enum {
|
|
ATH_DEBUG_RATE = 0x00000010, /* rate control */
|
|
Index: madwifi-ng-r2756-20071018/ath_rate/sample/sample.c
|
|
===================================================================
|
|
--- madwifi-ng-r2756-20071018.orig/ath_rate/sample/sample.c 2007-10-24 06:20:16.277616884 +0200
|
|
+++ madwifi-ng-r2756-20071018/ath_rate/sample/sample.c 2007-10-24 06:20:20.449854648 +0200
|
|
@@ -68,7 +68,7 @@
|
|
|
|
#include "sample.h"
|
|
|
|
-#define SAMPLE_DEBUG
|
|
+#undef SAMPLE_DEBUG
|
|
#ifdef SAMPLE_DEBUG
|
|
enum {
|
|
ATH_DEBUG_NODE = 0x00080000, /* node management */
|
|
Index: madwifi-ng-r2756-20071018/net80211/ieee80211_var.h
|
|
===================================================================
|
|
--- madwifi-ng-r2756-20071018.orig/net80211/ieee80211_var.h 2007-10-24 06:20:16.285617342 +0200
|
|
+++ madwifi-ng-r2756-20071018/net80211/ieee80211_var.h 2007-10-24 06:20:20.453854879 +0200
|
|
@@ -35,8 +35,8 @@
|
|
#ifndef _NET80211_IEEE80211_VAR_H_
|
|
#define _NET80211_IEEE80211_VAR_H_
|
|
|
|
-#define IEEE80211_DEBUG
|
|
-#define IEEE80211_DEBUG_REFCNT /* Node reference count debugging */
|
|
+#undef IEEE80211_DEBUG
|
|
+#undef IEEE80211_DEBUG_REFCNT /* Node reference count debugging */
|
|
|
|
/* Definitions for IEEE 802.11 drivers. */
|
|
#include <net80211/ieee80211_linux.h>
|
|
Index: madwifi-ng-r2756-20071018/tools/do_multi.c
|
|
===================================================================
|
|
--- madwifi-ng-r2756-20071018.orig/tools/do_multi.c 2007-10-24 06:20:17.249672281 +0200
|
|
+++ madwifi-ng-r2756-20071018/tools/do_multi.c 2007-10-24 06:20:20.453854879 +0200
|
|
@@ -9,16 +9,20 @@
|
|
|
|
progname = basename(argv[0]);
|
|
|
|
+#if 0
|
|
if(strcmp(progname, "80211debug") == 0)
|
|
ret = a80211debug_init(argc, argv);
|
|
+#endif
|
|
if(strcmp(progname, "80211stats") == 0)
|
|
ret = a80211stats_init(argc, argv);
|
|
if(strcmp(progname, "athchans") == 0)
|
|
ret = athchans_init(argc, argv);
|
|
if(strcmp(progname, "athctrl") == 0)
|
|
ret = athctrl_init(argc, argv);
|
|
+#if 0
|
|
if(strcmp(progname, "athdebug") == 0)
|
|
ret = athdebug_init(argc, argv);
|
|
+#endif
|
|
if(strcmp(progname, "athkey") == 0)
|
|
ret = athkey_init(argc, argv);
|
|
if(strcmp(progname, "athstats") == 0)
|
|
Index: madwifi-ng-r2756-20071018/tools/Makefile
|
|
===================================================================
|
|
--- madwifi-ng-r2756-20071018.orig/tools/Makefile 2007-10-24 06:20:17.253672511 +0200
|
|
+++ madwifi-ng-r2756-20071018/tools/Makefile 2007-10-24 06:20:20.453854879 +0200
|
|
@@ -48,7 +48,7 @@
|
|
|
|
|
|
ALLPROGS= athstats 80211stats athkey athchans athctrl \
|
|
- athdebug 80211debug wlanconfig ath_info
|
|
+ wlanconfig ath_info
|
|
|
|
OBJS= $(patsubst %,%.o,$(ALLPROGS) do_multi)
|
|
ALL= ${OBJS} madwifi_multi
|
|
@@ -84,7 +84,7 @@
|
|
${CC} -c -o do_multi.o -DDOMULTI=1 ${ALL_CFLAGS} do_multi.c
|
|
madwifi_multi: $(OBJS)
|
|
${CC} -o madwifi_multi ${LDFLAGS} ${OBJS}
|
|
- for i in athstats 80211stats athkey athchans athctrl athdebug wlanconfig 80211debug; do \
|
|
+ for i in athstats 80211stats athkey athchans athctrl wlanconfig; do \
|
|
ln -s -f madwifi_multi $$i; \
|
|
done
|
|
|