1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-19 18:15:27 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.22/005-adm5120_usb.patch
juhosg 1533187684 [adm5120] checkin a new, experimental USB driver
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8905 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-09-21 07:32:19 +00:00

36 lines
1.4 KiB
Diff

Index: linux-2.6.22.1/drivers/usb/host/Kconfig
===================================================================
--- linux-2.6.22.1.orig/drivers/usb/host/Kconfig
+++ linux-2.6.22.1/drivers/usb/host/Kconfig
@@ -237,3 +237,6 @@ config USB_SL811_CS
To compile this driver as a module, choose M here: the
module will be called "sl811_cs".
+config USB_ADM5120_HCD
+ tristate "ADM5120 HCD support (EXPERIMENTAL)"
+ depends on USB && MIPS_ADM5120 && EXPERIMENTAL
Index: linux-2.6.22.1/drivers/usb/host/Makefile
===================================================================
--- linux-2.6.22.1.orig/drivers/usb/host/Makefile
+++ linux-2.6.22.1/drivers/usb/host/Makefile
@@ -8,6 +8,7 @@ endif
obj-$(CONFIG_PCI) += pci-quirks.o
+obj-$(CONFIG_USB_ADM5120_HCD) += adm5120-hcd.o
obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o
obj-$(CONFIG_USB_OHCI_HCD) += ohci-hcd.o
Index: linux-2.6.22.1/drivers/usb/Makefile
===================================================================
--- linux-2.6.22.1.orig/drivers/usb/Makefile
+++ linux-2.6.22.1/drivers/usb/Makefile
@@ -16,6 +16,7 @@ obj-$(CONFIG_USB_UHCI_HCD) += host/
obj-$(CONFIG_USB_SL811_HCD) += host/
obj-$(CONFIG_USB_U132_HCD) += host/
obj-$(CONFIG_USB_OHCI_AT91) += host/
+obj-$(CONFIG_USB_ADM5120_HCD) += host/
obj-$(CONFIG_USB_ACM) += class/
obj-$(CONFIG_USB_PRINTER) += class/