1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 01:44:10 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.25/400-ledtrig_morse.patch
juhosg afc90574b4 [kernel] refresh generic 2.6.25 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11189 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-18 20:26:43 +00:00

23 lines
877 B
Diff

Index: linux-2.6.25.4/drivers/leds/Kconfig
===================================================================
--- linux-2.6.25.4.orig/drivers/leds/Kconfig
+++ linux-2.6.25.4/drivers/leds/Kconfig
@@ -181,4 +181,8 @@ config LEDS_TRIGGER_HEARTBEAT
load average.
If unsure, say Y.
+config LEDS_TRIGGER_MORSE
+ tristate "LED Morse Trigger"
+ depends on LEDS_TRIGGERS
+
endif # NEW_LEDS
Index: linux-2.6.25.4/drivers/leds/Makefile
===================================================================
--- linux-2.6.25.4.orig/drivers/leds/Makefile
+++ linux-2.6.25.4/drivers/leds/Makefile
@@ -26,3 +26,4 @@ obj-$(CONFIG_LEDS_HP6XX) += leds-hp6xx.
obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
+obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o