1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 14:32:25 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.25/410-gpio_buttons.patch
juhosg afc90574b4 [kernel] refresh generic 2.6.25 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11189 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-18 20:26:43 +00:00

35 lines
1.3 KiB
Diff

Index: linux-2.6.25.4/drivers/input/misc/Kconfig
===================================================================
--- linux-2.6.25.4.orig/drivers/input/misc/Kconfig
+++ linux-2.6.25.4/drivers/input/misc/Kconfig
@@ -197,4 +197,20 @@ config HP_SDC_RTC
Say Y here if you want to support the built-in real time clock
of the HP SDC controller.
+config INPUT_GPIO_BUTTONS
+ tristate "Polled GPIO buttons interface"
+ depends on GENERIC_GPIO
+ select INPUT_POLLDEV
+ help
+ This driver implements support for buttons connected
+ to GPIO pins of various CPUs (and some other chips).
+
+ Say Y here if your device has buttons connected
+ directly to such GPIO pins. Your board-specific
+ setup logic must also provide a platform device,
+ with configuration data saying which GPIOs are used.
+
+ To compile this driver as a module, choose M here: the
+ module will be called gpio-buttons.
+
endif
Index: linux-2.6.25.4/drivers/input/misc/Makefile
===================================================================
--- linux-2.6.25.4.orig/drivers/input/misc/Makefile
+++ linux-2.6.25.4/drivers/input/misc/Makefile
@@ -19,3 +19,4 @@ obj-$(CONFIG_INPUT_YEALINK) += yealink.
obj-$(CONFIG_HP_SDC_RTC) += hp_sdc_rtc.o
obj-$(CONFIG_INPUT_UINPUT) += uinput.o
obj-$(CONFIG_INPUT_APANEL) += apanel.o
+obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o