mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-08 23:04:03 +02:00
b0bea448ab
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2414 3c298f89-4303-0410-b956-a3cf2f4a3e73
23 lines
1.0 KiB
Diff
23 lines
1.0 KiB
Diff
--- linux.old/Rules.make 2005-08-31 00:37:34.363109288 +0200
|
|
+++ linux.dev/Rules.make 2005-08-31 13:59:20.140676296 +0200
|
|
@@ -126,7 +126,7 @@
|
|
# This make dependencies quickly
|
|
#
|
|
fastdep: dummy
|
|
- $(TOPDIR)/scripts/mkdep $(CFLAGS) $(EXTRA_CFLAGS_nostdinc) -- $(wildcard *.[chS]) > .depend
|
|
+ find -name '*.[chS]' | xargs $(TOPDIR)/scripts/mkdep $(CFLAGS) $(EXTRA_CFLAGS_nostdinc) -- > .depend
|
|
ifdef ALL_SUB_DIRS
|
|
$(MAKE) $(patsubst %,_sfdep_%,$(ALL_SUB_DIRS)) _FASTDEP_ALL_SUB_DIRS="$(ALL_SUB_DIRS)"
|
|
endif
|
|
--- linux-2.4.30/Makefile.old 2005-11-11 14:27:55.878482250 +0100
|
|
+++ linux-2.4.30/Makefile 2005-11-11 14:28:57.926360000 +0100
|
|
@@ -509,7 +509,7 @@
|
|
ifdef CONFIG_MODVERSIONS
|
|
$(MAKE) update-modverfile
|
|
endif
|
|
- scripts/mkdep -- `find $(FINDHPATH) \( -name SCCS -o -name .svn \) -prune -o -follow -name \*.h ! -name modversions.h -print` > .hdepend
|
|
+ find $(FINDHPATH) \( -name SCCS -o -name .svn \) -prune -o -follow -name \*.h ! -name modversions.h -print | xargs scripts/mkdep -- > .hdepend
|
|
scripts/mkdep -- init/*.c > .depend
|
|
|
|
ifdef CONFIG_MODVERSIONS
|