1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 01:44:10 +03:00
openwrt-xburst/target/lzma-loader/patches/toolchain.patch
kaloz 17f5f375fc optimize for size
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@780 3c298f89-4303-0410-b956-a3cf2f4a3e73
2005-04-30 21:11:50 +00:00

17 lines
865 B
Diff

diff -Nur loader-0.04/Makefile loader-0.04-owrt/Makefile
--- loader-0.04/Makefile 2005-03-08 11:32:32.000000000 +0100
+++ loader-0.04-owrt/Makefile 2005-04-30 13:44:39.000000000 +0200
@@ -22,9 +22,10 @@
OBJCOPY := $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
-CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -O2 \
+CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
-fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic \
- -ffunction-sections -pipe -mcpu=r4600 -mips2 -Wa,--trap -m4710a0kern
+ -ffunction-sections -pipe -mlong-calls -fno-common \
+ -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
CFLAGS += -DLOADADDR=$(TEXT_START) -D_LZMA_IN_CB
ASFLAGS = $(CFLAGS) -D__ASSEMBLY__ -DBZ_TEXT_START=$(BZ_TEXT_START)