mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-25 07:18:06 +02:00
26 lines
831 B
Diff
26 lines
831 B
Diff
--- a/drivers/power/Kconfig
|
|
+++ b/drivers/power/Kconfig
|
|
@@ -103,4 +103,15 @@ config CHARGER_PCF50633
|
|
help
|
|
Say Y to include support for NXP PCF50633 Main Battery Charger.
|
|
|
|
+config BATTERY_JZ4740
|
|
+ tristate "Ingenic JZ4720/JZ4740 battery"
|
|
+ depends on SOC_JZ4740
|
|
+ depends on JZ4740_ADC
|
|
+ help
|
|
+ Say Y to enable support for the battery on Ingenic JZ4720/JZ4740 based
|
|
+ boards.
|
|
+
|
|
+ This driver can be build as a module. If so, the module will be
|
|
+ called jz4740-battery.
|
|
+
|
|
endif # POWER_SUPPLY
|
|
--- a/drivers/power/Makefile
|
|
+++ b/drivers/power/Makefile
|
|
@@ -28,3 +28,4 @@ obj-$(CONFIG_BATTERY_BQ27x00) += bq27x00
|
|
obj-$(CONFIG_BATTERY_DA9030) += da9030_battery.o
|
|
obj-$(CONFIG_BATTERY_MAX17040) += max17040_battery.o
|
|
obj-$(CONFIG_CHARGER_PCF50633) += pcf50633-charger.o
|
|
+obj-$(CONFIG_BATTERY_JZ4740) += jz4740-battery.o
|