1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-03 20:12:25 +03:00
openwrt-xburst/target/linux/kirkwood/patches/000-boards.patch
luka 576ea25936 kirkwood: reorganize target
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32053 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-06-05 00:43:56 +00:00

39 lines
1.2 KiB
Diff

--- a/arch/arm/mach-kirkwood/Makefile
+++ b/arch/arm/mach-kirkwood/Makefile
@@ -18,5 +18,8 @@ obj-$(CONFIG_MACH_D2NET_V2) += d2net_v2
obj-$(CONFIG_MACH_NET2BIG_V2) += netxbig_v2-setup.o lacie_v2-common.o
obj-$(CONFIG_MACH_NET5BIG_V2) += netxbig_v2-setup.o lacie_v2-common.o
obj-$(CONFIG_MACH_T5325) += t5325-setup.o
+obj-$(CONFIG_MACH_ICONNECT) += iconnect-setup.o
+obj-$(CONFIG_MACH_NAS6210) += nas6210-setup.o
+obj-$(CONFIG_MACH_NSA310) += nsa-310-setup.o
obj-$(CONFIG_CPU_IDLE) += cpuidle.o
--- a/arch/arm/mach-kirkwood/Kconfig
+++ b/arch/arm/mach-kirkwood/Kconfig
@@ -130,6 +130,24 @@ config MACH_T5325
Say 'Y' here if you want your kernel to support the
HP t5325 Thin Client.
+config MACH_ICONNECT
+ bool "Iomega iConnect Wireless"
+ help
+ Say 'Y' here if you want your kernel to support the
+ Iomega iConnect Wireless.
+
+config MACH_NAS6210
+ bool "RaidSonic ICY BOX IB-NAS6210"
+ help
+ Say 'Y' here if you want your kernel to support the
+ RaidSonic ICY BOX IB-NAS6210 device.
+
+config MACH_NSA310
+ bool "ZyXEL NSA-310"
+ help
+ Say 'Y' here if you want your kernel to support the
+ ZyXEL NSA-310 board.
+
endmenu
endif