mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-07 18:11:52 +02:00
76d4ca5d50
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9244 3c298f89-4303-0410-b956-a3cf2f4a3e73
31 lines
1.2 KiB
Diff
31 lines
1.2 KiB
Diff
--- linux-2.6.22.4.orig/drivers/i2c/busses/Kconfig 2007-08-21 06:33:06.000000000 +0200
|
|
+++ linux-2.6.22.4/drivers/i2c/busses/Kconfig 2007-10-09 12:53:13.000000000 +0200
|
|
@@ -125,6 +125,17 @@
|
|
This is a very simple bitbanging I2C driver utilizing the
|
|
arch-neutral GPIO API to control the SCL and SDA lines.
|
|
|
|
+config I2C_GPIO_CUSTOM
|
|
+ tristate "Custom GPIO-based I2C driver"
|
|
+ depends on GENERIC_GPIO
|
|
+ select I2C_GPIO
|
|
+ help
|
|
+ This is an I2C driver to register 1 to 4 custom I2C buses using
|
|
+ GPIO lines.
|
|
+
|
|
+ This support is also available as a module. If so, the module
|
|
+ will be called i2c-gpio-custom.
|
|
+
|
|
config I2C_HYDRA
|
|
tristate "CHRP Apple Hydra Mac I/O I2C interface"
|
|
depends on PCI && PPC_CHRP && EXPERIMENTAL
|
|
--- linux-2.6.22.4.orig/drivers/i2c/busses/Makefile 2007-08-21 06:33:06.000000000 +0200
|
|
+++ linux-2.6.22.4/drivers/i2c/busses/Makefile 2007-10-09 12:07:45.000000000 +0200
|
|
@@ -13,6 +13,7 @@
|
|
obj-$(CONFIG_I2C_BLACKFIN_TWI) += i2c-bfin-twi.o
|
|
obj-$(CONFIG_I2C_ELEKTOR) += i2c-elektor.o
|
|
obj-$(CONFIG_I2C_GPIO) += i2c-gpio.o
|
|
+obj-$(CONFIG_I2C_GPIO_CUSTOM) += i2c-gpio-custom.o
|
|
obj-$(CONFIG_I2C_HYDRA) += i2c-hydra.o
|
|
obj-$(CONFIG_I2C_I801) += i2c-i801.o
|
|
obj-$(CONFIG_I2C_I810) += i2c-i810.o
|